troubleshooting Question

VMware hypervisor 6.7 (no vSphere) - Setting iscsi port binding

Avatar of Fabio Rosiglioni
Fabio Rosiglioni asked on
VMwareVirtualization
5 Comments1 Solution290 ViewsLast Modified:
I'm testing VMware ESXi 6.7 update 1, I tested ver 6.5 update 2 and I've found the same freak.
I'm using the hypervisor embedded client (no vSphere).
It works all regularly but I have a problem to setting iSCSI.

- I set 2 switches:
vSwitch1, ok
vSwitch2, ok
- I set up 2 VMkernel NICs and the 2 related port groups named iSCSI ...
vmk1 - iSCSI1, ok
vmk2 - iSCSI2, ok
- I added the vmnic2 and vmnic3 to vSwitch1, ok.
- I tried to add the same nic (vmnic2 and vmnic3) to vSwitch2, and the error message is:  "Can not add up - There are no physical adapters to attach to this visrtual switch."

- I tried from SSH console but without success:
esxcli network vswitch standard uplink add --uplink-name=vmnic2 --vswitch-name=vSwitch2

The VMware documentation for version 6.7 describes the same procedure (see the attached doc).

I have an installation that's using VmWare hypervisor 5.0 with the same configuration and it works.

Where is my mistake?
Or you can not configure iSCSI bindings from the embedded client

Fabio
Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 1 Answer and 5 Comments.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 1 Answer and 5 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros