USB Drive doesn't automatically mount when connected to MacBook Pro 10.11.6, but can be mounted using Disk Utility

computerlarry
computerlarry used Ask the Experts™
on
User's USB external drive does not automatically mount when connected to a MacBook Pro
When I run Disk Utility, I am able to get the drive to mount after I run disk repair, and then automatically mount.
Disk Utility shows that the drive is in the unmounted state after being connected to the MacBook Pro

What could be preventing the mounting?
Is a Mac OS upgrade required?
Is the drive damaged?
Are the Mac's USB ports a problem?


User has a MacBook Pro with Mac OS X 10.11.6
MacBook Pro Retina 2.2GHz Intel i7  - Mid 2014
16 GB RAM

Backup drive is Seagate Ultra Slim PL Media
1 TB, USB connection
Partition Map is Master Boot Record

Time Machine accepted this MBR drive as a backup drive
Would MBR partition keep the drive from being mounted?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Is the Seagate drive formatted as a Mac HFS+ partition, a Windows NTFS partition, or the newer Mac APFS partition?  If you didn't change the formatting, then it should be HFS+ if you bought a Mac Seagate disk and spent the extra money to have it be HFS+.  If you bought the generic (Windows) one, then you should have NTFS on it and you should install the free Seagate NTFS for OS X driver that's a trimmed down version of Paragon NTFS.

Windows NTFS partitions can be mounted on Macs but you need the Seagate free version of NTFS for OS X, or pay for the full Paragon NTFS.  If it's NTFS, you should check the NTFS for OS X preferences to be sure it wasn't turned off.  Macs can read NTFS, but writing is turned off by default.  You have to enable writing or use a driver.

Author

Commented:
I bought a Windows formatted drive, and then used the Mac OS Disk Utility to re-format as a Mac HFS+, but I see that the drive is currently a MBR.  I'm thinking that the Mac OS might have made the drive a MBR when I agreed to use the drive for Time Machine

Commented:
I do not have this problem, but I put an HFS+ partition on the NTSF (originally) drive. But that must have been done already  if Time Machine accepts the drive. So it should mount. But you can always do this:

How to "force" a drive mount "automatically":
  • Mount the drive using Disk Utility
  • Launch System Preferences
  • Select the Users & Groups preference (called Accounts in earlier versions of the Mac OS)
  • Click on the Lock icon, enter your user name and password, and click Unlock.
  • Now click on the Login Items tab to open it.
  • Drag the icon of the mounted drive into the list of login items.
  • Find it in the list and check the box on the right to tell the system to mount the drive.
  • Close.

Now reboot and see if that works. I have not done that in years, but it should be a workaround.
>What could be preventing the mounting?
Most likely is low level disk damage. Is there any LOG in Disk Utility after each repair in terms of what was fixed?

>Is a Mac OS upgrade required?
No

>Is the drive damaged?
Possibly/Probably .. if a Disk Repair is required every time you plug it in ..

>Are the Mac's USB ports a problem?
Not likely .. if possible plug the USB HD into another mac .. or try an alternative USB cable but the HD itself is a lot more likely.

>Would MBR partition keep the drive from being mounted?
No

Commented:
I am still unsure as to what the in the answers provided by Eoin solved your issue. Can you explain so we all know what you found? Thank you.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial