Outlook / iphone - Cannot get rid of suggested contacts

Hi

I am trying to clean up my contacts in IOS 12.x

So my initial step was to reset the iPhone to factory defaults, keeping icloud off completely. So absolutely no contacts on the pjhone at all.

Then I cleaned up my personal contacts in Outlook to just what I want. Then I deleted my autocomplete file in my profiles roamcahce directory. No suggestions are put forward when I type a letter in a new email. So far so good.

So now I set up my Exchange account which went OK. When I start to type an email address on my iPhone it shows literally hundreds of old emails addresses which I was trying to delete. Looking at the contacs app under contacs there are just my Outlook contacs, good, but there is another group called suggested contacts which contains all these mails. Even if I deselect this group and just have contacts ticked , when I start typing an address it shows everything.

Where is this junk stored in Outlook? It is not the autocomplete file as I deleted that. It must be outlook as I did an iPhone fiull erase and reset, set up as a new phone and made sure nothing Icloud was enabled. To be sure I user my laptop to log into icloud to check what contacts I had there and there were only 4.

Any ideas please?

Thanks

Aladair Barclay
AlasdairbAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
Outlook stores this in Stream_Autocomplete files in the USERs folder. Here is some additional information

https://answers.microsoft.com/en-us/msoffice/forum/all/how-do-i-move-a-streamautocompletedat-file-from/df277804-4cef-414f-aea3-8b85809f7724

iPhone also stores suggested contacts.

https://www.imore.com/how-to-remove-suggested-contacts-mail
Adam BrownSenior Systems AdminCommented:
The Autocomplete file isn't used in Exchange after Server 2010. It's stored in the mailbox. If you have Outlook, go to Options, Mail, Autocomplete, Scroll down to "Send Messages" and click the "Empty Autocomplete List".
AlasdairbAuthor Commented:
Hi both, thanks already removed my autocomplete cache and reset the iPhone and set up as a new phone with no icloud account. So it was neither of these.

I found the solution eventually. There really is a folder in your Outlook called Suggested Folders, it's just not shown by default.

In the bottom left of the Outlook screen click Folders and it will show you all the folders (including public folders) which are not shown by default. There you will see a contacts folder called Suggested Contacts, delete the entries in there and the problem is fixed.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
AlasdairbAuthor Commented:
Just kept ploughing on until I stumbled upon the answer
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
iOS

From novice to tech pro — start learning today.