troubleshooting Question

SQL Cluster Failed lost Primay SQL instance

Avatar of Thomas Grassi
Thomas GrassiFlag for United States of America asked on
Windows Server 2012SQL* Clustering
17 Comments2 Solutions116 ViewsLast Modified:
SQL 2014 Cluster 2 Nodes 3 instances
Windows 2012 R2
VMware ESXI 6.5
iSCSI drives

Today one of my iSCSI drives filled up.  I went onto SQL and tried to shrink a large data base trans log file it failed to do so I I tried to add another drive to the VM and I lost my  entire "E" drive on the 'E" drive is the install of the SQL 2014 server.   and the data bases.  I have backup drive of all databases and they are copied off to NAS drive daily.
My databases are ok

This instance was the first instance I installed and now it is gone.
I can get to the other instances but not the primary one.

The drives are shared between the nodes using iscsi and cluster manager.


I now have my E Drive back but it is empty.  I need to get the instance back.

So I tried to install SQL 2014 again  

I get to Cluster Node Configuration and it fails "There is no SQL Server failover cluster available to join.


Am I hosed?  Do I need to reinstall SQL from scratch?

Need assistance

Thank you

tom
Join the community to see this answer!
Join our exclusive community to see this answer & millions of others.
Unlock 2 Answers and 17 Comments.
Join the Community
Learn from the best

Network and collaborate with thousands of CTOs, CISOs, and IT Pros rooting for you and your success.

Andrew Hancock - VMware vExpert
See if this solution works for you by signing up for a 7 day free trial.
Unlock 2 Answers and 17 Comments.
Try for 7 days

”The time we save is the biggest benefit of E-E to our team. What could take multiple guys 2 hours or more each to find is accessed in around 15 minutes on Experts Exchange.

-Mike Kapnisakis, Warner Bros