Help my MacBook Pro keeps switching screens when resizing an image in one tool. It sends me to the desktop...?

I have a MACBook Pro latest OS. I have been working making screenshots for a manual using Snagit. A screen capture tool. If I try to resize the image I am working with. The second I LEFT MOUSE CLICK on the RESIZE box and try to resize with the mouse. It switches screens to the Apple Desktop...? What is happening? I went to System Pref and searched Google. The search turned up this.

"How do I stop my Mac from switching screens?
Click Apple menu from top left of your screen > Select System Preferences > in Personal Tab select Expose & Spaces > Deselect the check box that says Enable Spaces."

Only one problem I see no "Personal Tab" or "Expose Spaces" anywhere in System Preferences?

Any thoughts. I am about to throw my laptop across the room.
RUA Volunteer2?Tableau Trainer & Consultant Sales Exec.Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
I use Snagit for Windows.   Did you set the Hot Key in Snagit (you should be able to do that)?  Or use a different Hotkey for the Snagit operation. I do that for capture so as not to conflict with Windows keys.
serialbandCommented:
Expose and Spaces are controlled under Mission Control in the newest OS X.  However, I suspect this is not the issue.  Are you sure you're clicking on the correct resize box?  You could try using the built-in screen capture tool (command option 4 or command option 3) to grab an image of what you're trying to do.
RUA Volunteer2?Tableau Trainer & Consultant Sales Exec.Author Commented:
John  I m not on a Windows Machine. I have not set any HotKeys that I can tell. version Snagit 2019. Thanks for looking at this. I do appreciate everything you guys do. Here is the image in Snagit I am working with on my Mac. The second I left click on any of the resize boxes it flips to the Desktop Screen on the map. It is like it is auto switching on any click of my mouse to the Mac Desktop? This is Snagit for Mac and it shows the points from which I am trying to resize. Looking and searching under the Search box on System Prefs the Expose and Spaces under Mission Control in the newest OS X is not showing up.
Flipped-Out.png
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

JohnBusiness Consultant (Owner)Commented:
When you click on Snagit to Capture (not the Editor) there may be a setting to set Hotkeys.  I am not sure. There is such a Hotkey setting for me when I click on Capture.

You can contact Snagit Support as well as they are very good for helping.
RUA Volunteer2?Tableau Trainer & Consultant Sales Exec.Author Commented:
Contacted Snagit. That was a bust. They have the question. I spoke with tech support with chat. Their systems would not let me upload a common file even though they said it would. File types like MP4 and .Zip. The file was 23 mb and I will try to post it here if it is possible. Although it may not be able to upload.
FlippingOUTVideo.mp4
JohnBusiness Consultant (Owner)Commented:
I am not sure what more I might suggest.   Sorry about that.
RUA Volunteer2?Tableau Trainer & Consultant Sales Exec.Author Commented:
I have a sincere lack of knowledge of the Macs tricks of the trade here.  I am in the editor now looking under preferences and I see Preferences which I assume is for Snagit only. Then below in this image is I assume Apple's Service Preferences Like Windows Services I assume.Is Preferences for Snagit only and Service Prefs for Apple?When I go to More Preferences Nothing happens. No window pop up or out. Nothing. Is that where HotKeys are?
Is this where the hot keys are? I cannot find them anywhereI get this when I go to the Snagit Editor.
Snagit Editor Preferences
I have discovered that if any of the images that are resized due to a text box that is too large or if I accidentally Size Down an image with a incidental touch of a button. Then if I go to resize it back ..... it also switches to my desktop. Very weird.
serialbandCommented:
It's a Snagit bug, that they should fix.  I've never used Snagit on the Mac because Macs have a built-in screen capture and screen recording built into their Quicktime.app that are sufficient for my usage.  However, I've worked with people that have used an older version of Snaggit.  It didn't have the problem you're describing.

That services preference is likely for the main Mac Preferences.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JohnBusiness Consultant (Owner)Commented:
I looked up Snagit for MAC at TechSmith trying to help the author but did not see anything new.  

My own Snagit (Windows) does not interfere with my OS.
serialbandCommented:
Your own Snagit is not relevant.

There are more things in heaven and earth, Horatio,
Than are dreamt of in your philosophy.
- Hamlet
RUA Volunteer2?Tableau Trainer & Consultant Sales Exec.Author Commented:
This was the solution that TechSmith offered. Yeah I originally bought it for my Windows Machine and they said I get a Mac version as well so I said what the heck and installed it.

Remove com.techsmith.snagit.plist
-----------------------------------------------------
1.) Close Snagit and confirm its not running by accessing Activity Monitor.  Look for Snagit in the running list of applications.
2.) Click on your Finder and then click the Go menu at the top, then select Go to folder….
3.) Type the following and hit Enter:  ~/Library/Preferences/
4.) Locate all com.techsmith.snagit.plist files and move them to your trash
5.) Confirm that com.techsmith.snagit.plist is no longer in the Preferences folder.
6.) Reboot the computer and try Snagit again.

I will have to work on this tomorrow to see if the problem persists.
RUA Volunteer2?Tableau Trainer & Consultant Sales Exec.Author Commented:
That solution from Snagit Tech Support seems to have worked. Thank for all your help gentlemen.
RUA Volunteer2?Tableau Trainer & Consultant Sales Exec.Author Commented:
Good call apparently it is a bug all your suggestions helped me get to the conclusion so thank you.
JohnBusiness Consultant (Owner)Commented:
You are very welcome and I was happy to assist.  Thanks for the update.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apple OS

From novice to tech pro — start learning today.