Azure management certificates -  “You must be a co-worker administrator on the selected subscriptions to view management certificates”

sherlock1
sherlock1 used Ask the Experts™
on
Hi Experts,

In the Azure web management portal I’m trying to view management certificates and when I go to the following location: Subscriptions > company name > Management certificates
I see a message that says “You must be a co-worker administrator on the selected subscriptions to view management certificates”

I'Azure management certificatem using an account with Global administrative permissions. Im not sure why I can’t view this?. Do I need an additional level of permission to access this?

See attached screenshot of issue seen
Thanks
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Scott FellDeveloper & EE Moderator
Fellow 2018
Most Valuable Expert 2013

Commented:
What happened when you checked your permissions?

Author

Commented:
Please clarify what you mean?, do you mean what permissions do I have for my  account in Azure?
Scott FellDeveloper & EE Moderator
Fellow 2018
Most Valuable Expert 2013

Commented:
Yes.

Looking at my own portal and Access Control (IAM) and search my name, I am set up as:

Service Administrator  |  Has full access to all resources in the subscription

With that, I am able to go to the management certificate section.

Can you look up your access control?
Exploring SQL Server 2016: Fundamentals

Learn the fundamentals of Microsoft SQL Server, a relational database management system that stores and retrieves data when requested by other software applications.

Author

Commented:
Ok, i checked and looks like I have "Owner" (lets you manage everything , including access to resources)
so I guess service administrator is needed?

Thanks

Author

Commented:
Is the Service Administrator account an inbuilt account or does it need to be enabled?
I cant see an account with this name in Azure

Sorry about delay in further update

Thanks
Developer & EE Moderator
Fellow 2018
Most Valuable Expert 2013
Commented:
I am the only one on the account and that must have been the default. I did work with Azure help when I first started and can't remember everything we went over.  I did see I was set up as a classic administrator and just added myself as the role of Owner.

Under Management Certificates is a link for My Permissions. Click that. I get, "You are an administrator on the subscription....."  

Next, towards the top, there is a link for Access Control (AIM). Click on each of Role Assignments, Deny Assignments and Classic to see if anything stands out.  Next click on Roles and you should see 0's and 1's for each role by user or group.  On Role Assignments you can also check the scope.

I do see on the Add feature (top left plus sign), when you click that you can add a co-administrator.  Perhaps that is what needs to be done.


https://docs.microsoft.com/en-us/azure/role-based-access-control/role-assignments-portal
https://docs.microsoft.com/en-us/azure/active-directory/users-groups-roles/directory-assign-admin-roles
https://docs.microsoft.com/en-us/azure/billing/billing-add-change-azure-subscription-administrator

Author

Commented:
Thanks Scott four help on this, I was away for a bit - sorry about the delay getting back to you

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial