BGP Next Hop

BGP Next Hop

in the BGP configuration below, I am not sure why on R2 and R3 the next hop is not the IP address of R1 interfaces ,either( 192.168.12.1 or 192.168.13.1)
I mean on R2 to reach the loopback (3.3.3.3) of R3,  the Next-hop is showing the 192.168.13.3 and on R3 to reach the loopback(2.2.2.2) of R2, the Next-hop is showing 192.168.12.2
I thought the Next-hop should be the interfaces of R1either( 192.168.12.1 or 192.168.13.1)

I can ping 3.3.3.3 from R2 and 2.2.2.2 from R3

Thank you

bgp
R1#
interface Ethernet0/0
 ip address 192.168.12.1 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.13.1 255.255.255.0
!
router bgp 1
 bgp log-neighbor-changes
 neighbor 192.168.12.2 remote-as 1
 neighbor 192.168.12.2 route-reflector-client
 neighbor 192.168.12.2 next-hop-self
 neighbor 192.168.13.3 remote-as 1
 neighbor 192.168.13.3 route-reflector-client
 neighbor 192.168.13.3 next-hop-self

Open in new window


R2#
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Ethernet0/0
 ip address 192.168.12.2 255.255.255.0

router bgp 1
 network 2.2.2.2 mask 255.255.255.255
 neighbor 192.168.12.1 remote-as 1
 neighbor 192.168.23.3 remote-as 1

ip route 192.168.13.0 255.255.255.0 192.168.12.1

Open in new window



R3#
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface Ethernet0/0
 ip address 192.168.13.3 255.255.255.0

router bgp 1
 network 3.3.3.3 mask 255.255.255.255
 neighbor 192.168.12.2 remote-as 1
 neighbor 192.168.13.1 remote-as 1

ip route 192.168.12.0 255.255.255.0 192.168.13.1

Open in new window



R1#sh ip bgp
BGP table version is 7, local router ID is 192.168.13.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>i 2.2.2.2/32       192.168.12.2             0    100      0 i
 *>i 3.3.3.3/32       192.168.13.3             0    100      0 i
R1#

Open in new window


R2#show ip bgp 
BGP table version is 3, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  2.2.2.2/32       0.0.0.0                  0         32768 i
 *>i 3.3.3.3/32       192.168.13.3             0    100      0 i
R2#

Open in new window


R3#sh ip bgp
BGP table version is 3, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>i 2.2.2.2/32       192.168.12.2             0    100      0 i
 *>  3.3.3.3/32       0.0.0.0                  0         32768 i
R3#

Open in new window


R2#ping 3.3.3.3
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R2#

R3#ping 2.2.2.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
R3#
jskfanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

RafaelArchitect - Network Engineer - InstructorCommented:
Look at R2.

What is "neighbor 192.168.23.3 remote-as 1" ?  Looks like the IP is incorrect.

did you mean it to say 192.168.13.x ??

-Rafael
jskfanAuthor Commented:
Thank you,

corrected that and  cleared bgp, but still the same :
 
R2#sh run | sec bgp
router bgp 1
 bgp log-neighbor-changes
 network 2.2.2.2 mask 255.255.255.255
 neighbor 192.168.12.1 remote-as 1
 neighbor 192.168.13.3 remote-as 1
R2#

Open in new window


R3#sh run | sec bgp
router bgp 1
 bgp log-neighbor-changes
 network 3.3.3.3 mask 255.255.255.255
 neighbor 192.168.12.2 remote-as 1
 neighbor 192.168.13.1 remote-as 1
R3#

Open in new window






R2#sh ip bgp       
BGP table version is 3, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  2.2.2.2/32       0.0.0.0                  0         32768 i
 * i 3.3.3.3/32       192.168.13.3             0    100      0 i
 *>i                  192.168.13.3             0    100      0 i
R2#

Open in new window


R3#sh ip bgp       
BGP table version is 3, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 * i 2.2.2.2/32       192.168.12.2             0    100      0 i
 *>i                  192.168.12.2             0    100      0 i
 *>  3.3.3.3/32       0.0.0.0                  0         32768 i
R3#

Open in new window

Benjamin Van DitmarsSr Network EngineerCommented:
include connected interfaces in the redistributon
redistribure connected subnets on the routers that run ibgp
Price Your IT Services for Profit

Managed service contracts are great - when they're making you money. Yes, you’re getting paid monthly, but is it actually profitable? Learn to calculate your hourly overhead burden so you can master your IT services pricing strategy.

jskfanAuthor Commented:
After I redistributed connected, still the next-hop is the same:
R2#sh ip bgp
BGP table version is 5, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>  2.2.2.2/32       0.0.0.0                  0         32768 i
 * i 3.3.3.3/32       192.168.13.3             0    100      0 i
 *>i                  192.168.13.3             0    100      0 i
 *>  192.168.12.0     0.0.0.0                  0         32768 ?
 r i 192.168.13.0     192.168.13.3             0    100      0 ?
 r>i                  192.168.13.3             0    100      0 ?
R2#

Open in new window


R3#sh ip bgp
BGP table version is 5, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal, 
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter, 
              x best-external, a additional-path, c RIB-compressed, 
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 * i 2.2.2.2/32       192.168.12.2             0    100      0 i
 *>i                  192.168.12.2             0    100      0 i
 *>  3.3.3.3/32       0.0.0.0                  0         32768 i
 r i 192.168.12.0     192.168.12.2             0    100      0 ?
 r>i                  192.168.12.2             0    100      0 ?
 *>  192.168.13.0     0.0.0.0                  0         32768 ?
R3#

Open in new window

jskfanAuthor Commented:
unless if the Next-Hop is always supposed to be the Last Hop before the destination Network...
N. SpearsSr.Net.EngCommented:
Next hop self only changes the prefixes learned from EBGP peers, not route reflected IBGP prefixes. There is an option to do next hop self all.  If your version has that option it will change the next hop for IBGP and EBGP learned prefixes.
jskfanAuthor Commented:
I removed the Next-hop- self.. I agree it does not have any impact.

What I need to point out is I can ping loopback of R3  from R2 with source loopback of R2 and can do the same thing from the R3 source loopback.

At this point is Next-Hop important ?
jskfanAuthor Commented:
I will take it back (regarding the ping from loopback to loopback).. because I have static route that has achieved that on R2 and R3
R2(config)# ip route 3.3.3.3 255.255.255.255 192.168.12.1

R3(config)# ip route 2.2.2.2 255.255.255.255 192.168.13.1
RafaelArchitect - Network Engineer - InstructorCommented:
Can you redisplay the following and repost.

show ip route [bgp]
show ip bgp neighbors

Thanks
N. SpearsSr.Net.EngCommented:
Next hop self isn't important if your concern is IBGP routes. You are already using a route reflector and as stated next hop self is normally for EBGP announced prefixes.
jskfanAuthor Commented:
R1#sh ip route bgp 
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

R1#sh ip bgp nei
R1#sh ip bgp neighbors 
BGP neighbor is 2.2.2.2,  remote AS 1, internal link
  BGP version 4, remote router ID 0.0.0.0
  BGP state = Active
  Neighbor sessions:
    0 active, is not multisession capable (disabled)
    Stateful switchover support enabled: NO for session 0
  Message statistics:
    InQ depth is 0
    OutQ depth is 0
    
                         Sent       Rcvd
    Opens:                  0          0
    Notifications:          0          0
    Updates:                0          0
    Keepalives:             0          0
    Route Refresh:          0          0
    Total:                  0          0
  Default minimum time between advertisement runs is 0 seconds

 For address family: IPv4 Unicast
  BGP table version 4, neighbor version 1/4
  Output queue size : 0
  Index 0, Advertise bit 0
  Route-Reflector Client
  Slow-peer detection is disabled
  Slow-peer split-update-group dynamic is disabled
                                 Sent       Rcvd
  Prefix activity:               ----       ----
    Prefixes Current:               0          0
    Prefixes Total:                 0          0
    Implicit Withdraw:              0          0
    Explicit Withdraw:              0          0
    Used as bestpath:             n/a          0
    Used as multipath:            n/a          0

                                   Outbound    Inbound
  Local Policy Denied Prefixes:    --------    -------
    Total:                                0          0
  Number of NLRIs in the update sent: max 2, min 0
  Last detected as dynamic slow peer: never
  Dynamic slow peer recovered: never
  Refresh Epoch: 1
  Last Sent Refresh Start-of-rib: never
  Last Sent Refresh End-of-rib: never
  Last Received Refresh Start-of-rib: never
  Last Received Refresh End-of-rib: never
                		       Sent	  Rcvd
	Refresh activity:	       ----	  ----
	  Refresh Start-of-RIB          0          0
	  Refresh End-of-RIB            0          0

  Address tracking is enabled, the RIB does have a route to 2.2.2.2
  Connections established 1; dropped 1
  Last reset 00:14:54, due to Active open failed
  Transport(tcp) path-mtu-discovery is enabled
  Graceful-Restart is disabled
  No active TCP connection

BGP neighbor is 3.3.3.3,  remote AS 1, internal link
  BGP version 4, remote router ID 0.0.0.0
  BGP state = Active
  Neighbor sessions:
    0 active, is not multisession capable (disabled)
    Stateful switchover support enabled: NO for session 0
  Message statistics:
    InQ depth is 0
    OutQ depth is 0
    
                         Sent       Rcvd
    Opens:                  0          0
    Notifications:          0          0
    Updates:                0          0
    Keepalives:             0          0
    Route Refresh:          0          0
    Total:                  0          0
  Default minimum time between advertisement runs is 0 seconds

 For address family: IPv4 Unicast
  BGP table version 4, neighbor version 1/4
  Output queue size : 0
  Index 0, Advertise bit 0
  Route-Reflector Client
  Slow-peer detection is disabled
  Slow-peer split-update-group dynamic is disabled
                                 Sent       Rcvd
  Prefix activity:               ----       ----
    Prefixes Current:               0          0
    Prefixes Total:                 0          0
    Implicit Withdraw:              0          0
    Explicit Withdraw:              0          0
    Used as bestpath:             n/a          0
    Used as multipath:            n/a          0
          
                                   Outbound    Inbound
  Local Policy Denied Prefixes:    --------    -------
    Total:                                0          0
  Number of NLRIs in the update sent: max 2, min 0
  Last detected as dynamic slow peer: never
  Dynamic slow peer recovered: never
  Refresh Epoch: 1
  Last Sent Refresh Start-of-rib: never
  Last Sent Refresh End-of-rib: never
  Last Received Refresh Start-of-rib: never
  Last Received Refresh End-of-rib: never
				       Sent	  Rcvd
	Refresh activity:	       ----	  ----
	  Refresh Start-of-RIB          0          0
	  Refresh End-of-RIB            0          0

  Address tracking is enabled, the RIB does have a route to 3.3.3.3
  Connections established 1; dropped 1
  Last reset 00:14:11, due to Active open failed
  Transport(tcp) path-mtu-discovery is enabled
  Graceful-Restart is disabled
  No active TCP connection
          
R1# 

Open in new window



R2#sh ip route bgp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set


R2#
R2#sh ip bgp neighbors 
BGP neighbor is 1.1.1.1,  remote AS 1, internal link
  BGP version 4, remote router ID 0.0.0.0
  BGP state = Idle
  Neighbor sessions:
    0 active, is not multisession capable (disabled)
    Stateful switchover support enabled: NO
  Default minimum time between advertisement runs is 0 seconds

 For address family: IPv4 Unicast
  BGP table version 3, neighbor version 1/3
  Output queue size : 0
  Index 0, Advertise bit 0
  Slow-peer detection is disabled
  Slow-peer split-update-group dynamic is disabled
                                 Sent       Rcvd
  Prefix activity:               ----       ----
    Prefixes Current:               0          0
    Prefixes Total:                 0          0
    Implicit Withdraw:              0          0
    Explicit Withdraw:              0          0
    Used as bestpath:             n/a          0
    Used as multipath:            n/a          0

                                   Outbound    Inbound
  Local Policy Denied Prefixes:    --------    -------
    Total:                                0          0
  Number of NLRIs in the update sent: max 1, min 0
  Last detected as dynamic slow peer: never
  Dynamic slow peer recovered: never
  Refresh Epoch: 1
  Last Sent Refresh Start-of-rib: never
  Last Sent Refresh End-of-rib: never
  Last Received Refresh Start-of-rib: never
  Last Received Refresh End-of-rib: never
				       Sent	  Rcvd
	Refresh activity:	       ----	  ----
	  Refresh Start-of-RIB          0          0
	  Refresh End-of-RIB            0          0

  Address tracking is enabled, the RIB does not have a route to 1.1.1.1
  Connections established 1; dropped 1
  Last reset 00:15:41, due to Peer closed the session of session 1
  Transport(tcp) path-mtu-discovery is enabled
  Graceful-Restart is disabled
  No active TCP connection

BGP neighbor is 3.3.3.3,  remote AS 1, internal link
  BGP version 4, remote router ID 0.0.0.0
  BGP state = Idle
  Neighbor sessions:
    0 active, is not multisession capable (disabled)
    Stateful switchover support enabled: NO
  Default minimum time between advertisement runs is 0 seconds

 For address family: IPv4 Unicast
  BGP table version 3, neighbor version 1/3
  Output queue size : 0
  Index 0, Advertise bit 0
  Slow-peer detection is disabled
  Slow-peer split-update-group dynamic is disabled
                                 Sent       Rcvd
  Prefix activity:               ----       ----
    Prefixes Current:               0          0
    Prefixes Total:                 0          0
    Implicit Withdraw:              0          0
    Explicit Withdraw:              0          0
    Used as bestpath:             n/a          0
    Used as multipath:            n/a          0

                                   Outbound    Inbound
  Local Policy Denied Prefixes:    --------    -------
    Total:                                0          0
  Number of NLRIs in the update sent: max 0, min 0
  Last detected as dynamic slow peer: never
  Dynamic slow peer recovered: never
  Refresh Epoch: 1
  Last Sent Refresh Start-of-rib: never
  Last Sent Refresh End-of-rib: never
  Last Received Refresh Start-of-rib: never
  Last Received Refresh End-of-rib: never
				       Sent	  Rcvd
	Refresh activity:	       ----	  ----
	  Refresh Start-of-RIB          0          0
	  Refresh End-of-RIB            0          0

  Address tracking is enabled, the RIB does not have a route to 3.3.3.3
  Connections established 0; dropped 0
  Last reset never
  Transport(tcp) path-mtu-discovery is enabled
  Graceful-Restart is disabled
  No active TCP connection

R2# 

Open in new window



R3#sh ip route bgp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

R3#
R3#sh ip bgp neigh
R3#sh ip bgp neighbors 
BGP neighbor is 1.1.1.1,  remote AS 1, internal link
  BGP version 4, remote router ID 0.0.0.0
  BGP state = Idle
  Neighbor sessions:
    0 active, is not multisession capable (disabled)
    Stateful switchover support enabled: NO
  Default minimum time between advertisement runs is 0 seconds

 For address family: IPv4 Unicast
  BGP table version 3, neighbor version 1/3
  Output queue size : 0
  Index 0, Advertise bit 0
  Slow-peer detection is disabled
  Slow-peer split-update-group dynamic is disabled
                                 Sent       Rcvd
  Prefix activity:               ----       ----
    Prefixes Current:               0          0
    Prefixes Total:                 0          0
    Implicit Withdraw:              0          0
    Explicit Withdraw:              0          0
    Used as bestpath:             n/a          0
    Used as multipath:            n/a          0

                                   Outbound    Inbound
  Local Policy Denied Prefixes:    --------    -------
    Total:                                0          0
  Number of NLRIs in the update sent: max 1, min 0
  Last detected as dynamic slow peer: never
  Dynamic slow peer recovered: never
  Refresh Epoch: 1
  Last Sent Refresh Start-of-rib: never
  Last Sent Refresh End-of-rib: never
  Last Received Refresh Start-of-rib: never
  Last Received Refresh End-of-rib: never
				       Sent	  Rcvd
	Refresh activity:	       ----	  ----
	  Refresh Start-of-RIB          0          0
	  Refresh End-of-RIB            0          0

  Address tracking is enabled, the RIB does not have a route to 1.1.1.1
  Connections established 1; dropped 1
  Last reset 00:16:25, due to Peer closed the session of session 1
  Transport(tcp) path-mtu-discovery is enabled
  Graceful-Restart is disabled
  No active TCP connection

BGP neighbor is 2.2.2.2,  remote AS 1, internal link
  BGP version 4, remote router ID 0.0.0.0
  BGP state = Idle
  Neighbor sessions:
    0 active, is not multisession capable (disabled)
    Stateful switchover support enabled: NO
  Default minimum time between advertisement runs is 0 seconds

 For address family: IPv4 Unicast
  BGP table version 3, neighbor version 1/3
  Output queue size : 0
  Index 0, Advertise bit 0
  Slow-peer detection is disabled
  Slow-peer split-update-group dynamic is disabled
                                 Sent       Rcvd
  Prefix activity:               ----       ----
    Prefixes Current:               0          0
    Prefixes Total:                 0          0
    Implicit Withdraw:              0          0
    Explicit Withdraw:              0          0
    Used as bestpath:             n/a          0
    Used as multipath:            n/a          0

                                   Outbound    Inbound
  Local Policy Denied Prefixes:    --------    -------
    Total:                                0          0
  Number of NLRIs in the update sent: max 0, min 0
  Last detected as dynamic slow peer: never
  Dynamic slow peer recovered: never
  Refresh Epoch: 1
  Last Sent Refresh Start-of-rib: never
  Last Sent Refresh End-of-rib: never
  Last Received Refresh Start-of-rib: never
  Last Received Refresh End-of-rib: never
				       Sent	  Rcvd
	Refresh activity:	       ----	  ----
	  Refresh Start-of-RIB          0          0
	  Refresh End-of-RIB            0          0

  Address tracking is enabled, the RIB does have a route to 2.2.2.2
  Connections established 0; dropped 0
  Last reset never
  Transport(tcp) path-mtu-discovery is enabled
  Graceful-Restart is disabled
  No active TCP connection

R3#

Open in new window

N. SpearsSr.Net.EngCommented:
Post the output of sho ip route on your 3 routers. Currently it looks like you aren't even using any BGP routes.  So they must be resorting to an underlying IGP, connected, or static routes.
N. SpearsSr.Net.EngCommented:
Another thing to remember is IBGP routes have a high adminstrative distance, so though they show in the BGP table, they usually don't show in the RIB.
Benjamin Van DitmarsSr Network EngineerCommented:
ibgp is next hop resolution rtr2 cant have a session to rtr3

Bgp config router 1

router bgp 1
 bgp log-neighbor-changes
 neighbor 192.168.12.2 remote-as 1
 neighbor 192.168.13.3 remote-as 1
 !
 address-family ipv4
  redistribute connected
  neighbor 192.168.12.2 activate
  neighbor 192.168.12.2 route-reflector-client
  neighbor 192.168.12.2 next-hop-self
  neighbor 192.168.13.3 activate
  neighbor 192.168.13.3 route-reflector-client
  neighbor 192.168.13.3 next-hop-self
 exit-address-family
!

route table

For address family: IPv4 Unicast
BGP table version is 21, local router ID is 192.168.13.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i2.2.2.2/32       192.168.12.2             0    100      0 i
*>i3.3.3.3/32       192.168.13.3             0    100      0 i
* i192.168.12.0     192.168.12.2             0    100      0 ?
*>                  0.0.0.0                  0         32768 ?
* i192.168.13.0     192.168.13.3             0    100      0 ?
*>                  0.0.0.0                  0         32768 ?

Bgp config router 2

router bgp 1
 bgp router-id 2.2.2.2
 bgp log-neighbor-changes
 neighbor 192.168.12.1 remote-as 1
 !
 address-family ipv4
  network 2.2.2.2 mask 255.255.255.255
  redistribute connected
  neighbor 192.168.12.1 activate
  neighbor 192.168.12.1 soft-reconfiguration inbound
 exit-address-family
!

route table

BGP table version is 7, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, x best-external, f RT-Filter
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 2.2.2.2/32       0.0.0.0                  0         32768 i
*>i3.3.3.3/32       192.168.13.3             0    100      0 i
* i192.168.12.0     192.168.12.1             0    100      0 ?
*>                  0.0.0.0                  0         32768 ?
*>i192.168.13.0     192.168.12.1             0    100      0 ?

Bgp config router 3

router bgp 1
 bgp router-id 3.3.3.3
 bgp log-neighbor-changes
 neighbor 192.168.13.1 remote-as 1
 !
 address-family ipv4
  redistribute connected
  neighbor 192.168.13.1 activate
  neighbor 192.168.13.1 soft-reconfiguration inbound
  network 3.3.3.3 mask 255.255.255.255
 exit-address-family
!

For address family: IPv4 Unicast
BGP table version is 10, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i2.2.2.2/32       192.168.12.2             0    100      0 i
*> 3.3.3.3/32       0.0.0.0                  0         32768 i
*>i192.168.12.0     192.168.13.1             0    100      0 ?
* i192.168.13.0     192.168.13.1             0    100      0 ?
*>                  0.0.0.0                  0         32768 ?


also delete the static routes, they will be learned by bgp
N. SpearsSr.Net.EngCommented:
Good catch Benjamin :)
Benjamin Van DitmarsSr Network EngineerCommented:
i had some time spare, and a couple of router from a lab on the desk. ;)
so i just build his setup fast.

he was also missing his redistribution of the connected loopback.
jskfanAuthor Commented:
Benjamin Van Ditmars

Thank you... Corrected as suggested



So on R2 next hop is the ip address of R3
*>i3.3.3.3/32       192.168.13.3             0    100      0 i


and on R3  the next hop is the ip address of R2

  Network          Next Hop            Metric LocPrf Weight Path
*>i2.2.2.2/32       192.168.12.2             0    100      0 i
Benjamin Van DitmarsSr Network EngineerCommented:
yes, this is correct, router 2 and 3 cant directly connect to the other. for this reason next-hop self. router 1 has all the routes and all traffic will flow through

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jskfanAuthor Commented:
in this lab, the neighborship  peering  is done on directly connected interfaces on the links 192.168.12.0 and 192.168.13.0

if I need to build the neighborship peering just on Loopback interfaces behind R2 and R3, is that possible ?
I mean in addition to Update-Source Loopback commands that will be issued on R2 and R3 then will I need to use static routes for reachability  between all routers including physical and loopback interfaces?

this is just brief question and I will test it in a LAB and post new question later

Thank you
jskfanAuthor Commented:
Thank you
Benjamin Van DitmarsSr Network EngineerCommented:
youre welcome
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.