weird wifi behavior of my Android phone?

So I've got a wifi access point here that I am able to connect to with my Huawei Mate 20 Pro. But it seems like the phone is not always actually using the wifi to access the Internet!? I noticed this when I was unable to start Youtube (I've restricted its use to wifi). But if I'm in flight mode and then only enable wifi, it DOES use the access point to access the Internet ( > Youtube works). So why doesn't the phone do this with 4G enabled? Especially since I'm standing right new to the access point.
XeronimoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
Try the following (works on my iPhone):

1. Remove any superfluous Wi-Fi points you no longer need.

2. Go to Settings and put in Airplane Mode for 30 seconds.

3. Remove from Airplane Mode and test.

This flushes DNS and may help you.
XeronimoAuthor Commented:
Hm, no, that doesn't work ... although Youtube seems to work for about 10 seconds after disabling flight mode (when there's no 4G yet, it seems). But once the '4G' sign appears in the status bar then Youtube doesn't work anymore, which means that Internet comes in via data and not wifi!?
AlexProject Systems EngineerCommented:
Have you rooted your phone?
Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

XeronimoAuthor Commented:
No
JohnBusiness Consultant (Owner)Commented:
After you try the above steps, try turning the phone OFF (power down) and then restart.

Is your Phone operating system up to date?
AlexProject Systems EngineerCommented:
https://www.getdroidtips.com/common-huawei-mate-20-pro-problems/

Have you checked everything in that checklist yet before we go through something else?

Thanks
Alex
XeronimoAuthor Commented:
John: yes, it's up to date. and I've also restarted it. the problem also is with just this access point (or wifi network?). It works fine with my wifi at home.
JohnBusiness Consultant (Owner)Commented:
Try deleting the problem Profile , restart and re-make it
XeronimoAuthor Commented:
Alex: yes, I have. and wifi access works perfectly with my home wifi, for example.
XeronimoAuthor Commented:
John: what do you mean with 'profile' in this case?
AlexProject Systems EngineerCommented:
You need to forget the network and reconnect to it is what he means.
JohnBusiness Consultant (Owner)Commented:
Delete the Wireless point in the wireless Settings
KimputerIT ManagerCommented:
In the Wifi section where you connect to the networks, should be a menu button, revealing the Advanced options.
Sometimes, there's a "Switch to mobile data" option, with the description "Switch to mobile whenever your wifi internet connection is slow or unstable".
Try to turn this feature off. Maybe it falsely marks your wifi as slow or unstable (or maybe it truly is slow and unstable? Try again, moving closer to the AP?).
XeronimoAuthor Commented:
John: I have deleted and added the network, problem remains the same
AlexProject Systems EngineerCommented:
Disable WiFi + and see if that helps.

Regards
Alex
XeronimoAuthor Commented:
Kimputer: 'wi-fi+' (which does what you've described there) is disabled. and the wifi is definitely fast.
XeronimoAuthor Commented:
Alex: it's been disabled for a while
AlexProject Systems EngineerCommented:
Ok,

If it works fine at home but not on this particular WiFi, it's got to be the WiFi you're connecting to.

Regarss
Alex
XeronimoAuthor Commented:
Alex: yes, but I wonder why the access works if I'm in flight mode (with wifi enabled) but not if flight mode has been disabled?
AlexProject Systems EngineerCommented:
Is this a work mobile???
XeronimoAuthor Commented:
No, it's my private one
AlexProject Systems EngineerCommented:
..... I'd say try a factory reset and try again, putting it bluntly you've done all the regular stuff, the only exception would be if it's a work phone on a moraki network, I know you can block out data on phones in the office via that for security.

I'd backup everything and rebuild, that's the only thing left and essentially, that could rectify your issue or not and then you've still got to restore.
JohnBusiness Consultant (Owner)Commented:
If you are willing to do the factory reset, that is a good idea. You have followed all of our suggestions
XeronimoAuthor Commented:
Hm, not too keen on a factory reset, not really worth it in this case ... I was just interested as to WHY this happened ... 'why' being Internet access via wifi only if there's no data connection.
KimputerIT ManagerCommented:
Sometimes, "why" is very very hard to track down. Sounds like a system bug in this case, that might only be solved in a next firmware upgrade.
Can you still try to operate for a few minutes in Wifi+ mode (I know you don't need it, it's because I want it to force the switch internally), then turn the option off?
XeronimoAuthor Commented:
Kimputer: that doesn't work either. Each time 4G (data) gets activated wifi is being ignored ...
XeronimoAuthor Commented:
small update: I don't even need to go into flight mode and re-enable the wifi setting in order to access the Internet via the access point. It's enough to simply disable the 'mobile data' setting. then the phone will use the wifi to access the Internet as well.

so as long as mobile data is enabled the phone will not use the wifi that's right next to it ... only when mobile data is disabled will it use the wifi!
JohnBusiness Consultant (Owner)Commented:
I guess, then, leave it as is at least right now.
Jackie Man IT ManagerCommented:
Can you give details on you access point setup?
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Wireless Networking

From novice to tech pro — start learning today.