Google.com replaced by something else

Richard Korts
Richard Korts used Ask the Experts™
on
Somehow, when I go to google.com, I now get this.

http://search.hdownloadmyinboxhelper.com/?uc=20190318&ad=appfocus1&source=d-ccc3-lp0-r2-cp_1581138459-bb9&uid=86eef5f8-0e9f-492a-96d0-97d51529b595&i_id=email_100.20&page=newtab&

How do I fix that?

I'm using Firefox, I don't have time to try other browsers.

Thanks
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Dr. KlahnPrincipal Software Engineer

Commented:
Your browser's default search has been hijacked.

Look in Firefox under Tools, Add-Ons to see what plugins are present.  You'll probably see one you did not install.  Remove it.

Then click on the search engine icon in the search bar and select "Manage Search Engines."  Set the default search back to Google.

Close Firefox, reopen it and the problem should be gone.  If not, bring up your antivirus and sweep the system, then sweep again with Malwarebytes free version, then sweep again with Spybot - Search and Destroy.
Checking for fishy plugins and a virus scan should fix the root cause. Mind that redirection could also be caused by a modification of your hosts file ("C:\Windows\System32\drivers\etc\hosts") - You can open it with your notepad and if you find any lines that include the address you have mentioned, or a shortened URL, delete them or put a # sign before them.
Richard KortsBusiness Owner / Chief Developer

Author

Commented:
My Firefox does not have same look as you are describing. There is no "Tools", there is Addons

See attachments.

What now?

Thank you
menu.jpg
plugins.PNG
To see the Menu Bar you would Right-Click in a blank area to the right of an open tab (after you closed some so you have a blank space in the dark blue area) and select "Menu Bar".  That would allow you to use the "Tools" menu, however the hamburger icon (3 horizontal lines) at the top right that you clicked on is roughly equivalent to the "Tools" menu.  Repeat the Right-Click option to hide the Menu Bar if you don't like seeing it.

The "Add-Ons" window has defaulted to your "Plugins".  Look up a bit and you will see "Extensions" above this at the left.  Click on that and take a screenshot or type a list of the extensions that have been enabled by Firefox.

Under the Help menu you should have an option to "Restart with Add-Ons disabled".  Choose that and see if it goes to the Google home page or still goes to the other website.
Business Owner / Chief Developer
Commented:
I haven't had a chance to deal with this, but somehow, it went away.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial