We help IT Professionals succeed at work.

Synology RS2414rp+ SLOW READ PERFORMANCE.

126 Views
Last Modified: 2019-03-18
Hey guys

I setup 2x SSD's samsung 1TB on raid1 that is gonna be used for a few VMs for the next 2 months.

i setup raid 1 with BTRFS. Setup a single lun with advanced features. connected to it with ms iscsi initiator.

Everything works. I see the drive, i initialize it and format it with NTFS.

The Rackstation is connected with 1 gb cable to a gigabit switch. Jumbo frames 9000 enabled.

Big files transfer really really fast. back and forward. (maxed out 125 mb/s)

What i have an issue is, when i run atto benchmark on it, all the READS are maxed out at jokingly 5 to 11 mb/s??

The write speeds are doing better but not by much until i reach bigger files.

I am monitoring cpu and network usage on the GUI but there is absolutely no load / stress on the machine.

Supposedly this rackstation can do better than that?.

Here is what i have tried:


- Enable / disable jumbo frames = no change

- Trying out EXT4 instead of BTRFS = Gave around 20% boost but reads still stuck at 11 mb/s

- Trying different allocation sizes with NTFS (4k to 64k all the way) = small difference

- Trying ReFS = No difference

- Tried SMB3 mapped drive = no difference.

- Turning off all unnessercary services = no difference.

- Tried 3 different machines with different OS (server 2012R2, server 2016 and server 2019) = No difference

- Tried the raid "Sync faster" options = gave better results with normal operation but benchmark still shows bad.

- Tried directly cabling servers to the SAN with ip (no gateway). Same issue.

- Tried adding 4 TB WD reds. Same bad performance on read.

There is no MPIO setup.. just single Gigabit connection with iscsi.


Any device on the switch can transfer gigabit speeds with no issue.

Please help.. Getting desperate.
Comment
Watch Question

David FavorFractional CTO
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
The 11 mb/s cap looks suspiciously like maybe your routing table has set a 10mb/s interface card with a preferred network metric, where traffic sometimes flows over a slower pathway.

Setup iperf3 + test your raw IP speed, then move on to testing your DNS lookup correctness (same IP from all NS servers), then move on to checking your routing table has correct metrics to prefer fastest network at all times.
Mohammad ZeidTechnician

Author

Commented:
I just ran iperf between the RP2414rp+ and local server. See attached for result.

It looks fairly normal for a gigabit connection.
IPERF2019-03-18_21-57-35.png
Mohammad ZeidTechnician

Author

Commented:
Works perfectly on ubuntu!
ubuntu-2019-03-18_22-59-17.pngSo why is server 2016 / 2019 not doing well? How do we fix it on windows?
Technician
Commented:
This one is on us!
(Get your first solution completely free - no credit card required)
UNLOCK SOLUTION

Gain unlimited access to on-demand training courses with an Experts Exchange subscription.

Get Access
Why Experts Exchange?

Experts Exchange always has the answer, or at the least points me in the correct direction! It is like having another employee that is extremely experienced.

Jim Murphy
Programmer at Smart IT Solutions

When asked, what has been your best career decision?

Deciding to stick with EE.

Mohamed Asif
Technical Department Head

Being involved with EE helped me to grow personally and professionally.

Carl Webster
CTP, Sr Infrastructure Consultant
Empower Your Career
Did You Know?

We've partnered with two important charities to provide clean water and computer science education to those who need it most. READ MORE

Ask ANY Question

Connect with Certified Experts to gain insight and support on specific technology challenges including:

  • Troubleshooting
  • Research
  • Professional Opinions
Unlock the solution to this question.
Join our community and discover your potential

Experts Exchange is the only place where you can interact directly with leading experts in the technology field. Become a member today and access the collective knowledge of thousands of technology experts.

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.