remote desktop services

I have installed RDP gateway on windows server 2019 and went through the configuration. I was unable to disable UDP 3391 transport in RDP Gateway windows server 2019

I tried it on 2 separate windows 2019 servers that used the normal install and no GPOs.

Any idea how to get it to turn off. We do not want to use UDP 3391 due to the port being blocked throughout the enterprise.

It is disabled In windows server 2016 by default. I actually would get the same error if I tried to enable it in windows server 2016. But for the scope of the question, We are trying to disable it in 2019.
uncheckUDP.jpg
errortransport.jpg
LVL 5
onlinerackAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AlexProject Systems EngineerCommented:
Sounds silly, can you launch that with administrative rights, I.E right click, run as admin.

Thanks
Alex
Dirk KotteSECommented:
why you need to disable the UDP port?
if UDP connection is not possible, server & client should use TCP.
(without user/admin interaction)
onlinerackAuthor Commented:
So if UDP is on but the user had the port blocked for that port, it would use only the TCP port?
Expert Spotlight: Joe Anderson (DatabaseMX)

We’ve posted a new Expert Spotlight!  Joe Anderson (DatabaseMX) has been on Experts Exchange since 2006. Learn more about this database architect, guitar aficionado, and Microsoft MVP.

Dirk KotteSECommented:
Yes.
If you use wireshark, you see connection is established with TCP first, than the connection try to switch to UDP.
i see the blocked UDP packets at the firewall, but the connection keeps stable.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
onlinerackAuthor Commented:
Thanks guys. It makes sense. That is reassuring.

In this case specifically, I had to disable UDP as it is not allowed through the firewalls from the client side. I did that eventually through the registry. But knowing that it would fail back to TCP is good to know.

@alex, good thought, Running as administrator these days with windows is the same as let's reboot to see if that clears it. MS picked that as a new trend.   I tried it, it did not work. I had some hope...

Thank you all for your contributions.
AlexProject Systems EngineerCommented:
Me too, but unfortunately that's the only thing I can offer since I've never set one of these up.

I'll step down so the other experts can have another look :D
onlinerackAuthor Commented:
You did good Alex... It really could have been that simple. This seems to be an issue with all windows 2019 out of the box as I ran three different installs.
The issue is now marked as resolved as I did the change through the registry.  Dirk, however, did provide valid info that if UDP is blocked, then it would use the TCP only anyways.

Thank you. :)
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2019

From novice to tech pro — start learning today.