azure backup not working- failing within few seconds

hi,
got a windows server 2016.
got azure backup configured.
backups failing within few seconds. i have attached a screenshot of the error.
azure.PNG
have tried:
1- registering the server. re registered successfully
2 - updated mars agent. 2.0.9153.0

still no luck. any help would be great.
Mr.XAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Jose Gabriel Ortega CastroEE Rookie/Solution Guide/Topic Advisor and CEO Faru Bonon ITCommented:
Click on more information and post us what you get.
Also, search on event viewer for any error related.
Mr.XAuthor Commented:
hi, sorry about the delay. actualyl raised with microsoft, as they are managing this backup. and still they are investigating.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage Software

From novice to tech pro — start learning today.