Unable to add vcenter to domain

mike shaoul
mike shaoul used Ask the Experts™
on
tried to add vcenter 6.7 to 2016 domain. received error : "Idm client exception: Error trying to join AD, error code [31], user [admin@corp.local], domain [corp.local], orgUnit []"

tried different administrator account and checked both domain admins, also used "username@domain" as the user to add the vcenter to pdc.
This is in a VMware 15 workstation lab.
The firewall is blank on vcenter and disabled on pdc.

Can ping ok the domain from SSH connection to vcenter, can ping esxi host ok and PDC.

I tried to add an esxi host that was added to a datacentre on vcenter. Success!
So why cant I add the vcenter to the domain ?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Seth SimmonsSr. Systems Administrator

Commented:
2 things..

1) is port 445 open?

2) is vCenter 6.7 at update 1?
starting with Update 1 provides support 2016 AD

VMware vCenter Server 6.7 Update 1 Release Notes
https://docs.vmware.com/en/VMware-vSphere/6.7/rn/vsphere-vcenter-server-671-release-notes.html

Author

Commented:
Hi Seth,
There are no firewall entries in my vcenter and I had disabled the firewall on the 2016 pdc.
My vcenter version is 6.7.0.200000 , which is 6.7 U1.

so any other ideas ?
in the end I reinstalled vcsa as didn't have issues.  may be I setup vcsa with ip instead of fqdn ?

Author

Commented:
thanks seth :)

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial