Getting an error when attempting to create a dataset from a new FetchXML datasource

D365 Online 9.1, SSRS FetchXML

We are working on converting a report to FetchXML.  We started with a new report and added a MSFetch datasource.  However, when attempted to create a dataset from the datasource, we get the error:

Invalid URI: The Authority/Host could not be parsed.
----------------------------
The URL "https:\msddev1.crm.dynamics.com" that you specified is invalid. Specify a valid URL, and try again.

We added the organization unique name from Customizations :: Developer Resources but still get the error (i.e. https:\msddev1.crm.dynamics.com;msddev1)

Your help is appreciated.
LVL 1
apollo7Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Chinmay PatelChief Technology NinjaCommented:
The URL should be in this format:
https://msddev1.crm.dynamics.com
apollo7Author Commented:
Chinmay, thanks for the correction - typo copied from OneNote :(  Anyway, when I correct it, it doesn't throw an error but gives me the endless loop of not able to login to any organizations.  

When I get to the query designer login, I get the list of organizations but it  does not allow me to login as my user .  

The error log states You don't have permission to access any of the organizations in the Microsoft Dynamics CRM Online region that you specified. If you're not sure which region your organization resides in, choose "Don't know" for the CRM region and try again. Otherwise check with your CRM administrator.

Does this mean I need additional Office365 privileges?
apollo7Author Commented:
I tried using a different company to connect the Fetch datasource to and it just hangs. I tried another with 4 different portals and it would not connect to any of them.  What causes this when the URL and credentials work connecting to CRM Online but not to a Fetch datasource inside a report.
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

Chinmay PatelChief Technology NinjaCommented:
Not sure why it would hang like that. Are you seeing any errors in the error log?
apollo7Author Commented:
Yes, it is attached.
Login_ErrorLog.log
apollo7Author Commented:

Also, when I try other companies to connect to,  get a few problems but no error log:

1. Shows multiple orgs, select one and the query designer opens and says "Loading Query Designer" then hangs
2. "Cant use cached credentials" (below)

Cant login

It seems to be that the query designer cant login using the credentials supplied.

Chinmay PatelChief Technology NinjaCommented:
Looks like you are using an older/mismatched version of Report Authoring Tools, are you sure you have the latest version installed?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Rikin ShahMicrosoft Dynamics CRM ConsultantCommented:
Hi Apollo7,

Whenever you get the error, remove all information from the username and password textboxes. And select none/first option from the Online Region selection and hit login. It will take you to a unique login page. Enter your credentials there and check.
apollo7Author Commented:
Thanks, I got this to work  and I am creating Fetch with VS and the FetchXML Builder from XrmToolBox.  I am struggling with some Fetch involving Stringmap, I have included the SQL and Fetch below.  It converts to Fetch but it doesn't produce the desired results.

Please advise

SQL
select Value
from FilteredStringMap
where FilteredViewName ='FilteredFEI_nanoportdemo'
and attributename = 'fei_nano_nnplocation'

Open in new window


FETCH
<fetch mapping="logical" version="1.0">
  <entity name="StringMap">
    <attribute name="Value" />
    <filter>
      <condition attribute="ViewName" operator="eq" value="FEI_nanoportdemo" />
      <condition attribute="attributename" operator="eq" value="fei_nano_nnplocation" />
    </filter>
  </entity>
</fetch>

Open in new window

Rikin ShahMicrosoft Dynamics CRM ConsultantCommented:
Hi,

This would be another question.. However, you just need to replace <attribute name="Value" /> with <attribute name="attributevalue" />
apollo7Author Commented:
Thanks, will start another question for this thread
apollo7Author Commented:
These answers allowed me to solve the problem by matching the Report Authoring versions and correcting the syntax that was pointed out.

Thanks
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Dynamics

From novice to tech pro — start learning today.