When trying to configure the mail flow rule to encrypt external email, there is no RMS template in the dropdown menu

We are trying to enable encryption on a clients Office365 tenant, but I am running into a wall that MS support have been able to help with. When trying to configure the mail flow rule to encrypt external email, there is no RMS template in the dropdown menu to select them. Azure Information Protection has already been enabled (so the old OME settings will not work), but the section for changing the RMS templates is not where the article that MS sent me said it would be. Does anyone know how to add an RMS template to the tenant?

No RMS in the rule settings
FrogworksAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Adam BrownSenior Systems AdminCommented:
Make sure you go through all the steps here: https://acbrownit.com/2018/05/25/enabling-message-encryption-in-office-365/

If you have, go into the Azure Information Protection settings in the Azure Portal (Not office 365) to make sure there are valid Rights Management Templates available in there. Note that enabling Azure Information Protection *can* take some time to apply in the tenant.
FrogworksAuthor Commented:
I have done all of these steps, but the OME defaults aren't showing up when I go to apply the RMS in a mail flow rule. The settings have been in place for well over a week now.

Does every user need to have the license for this to work?
Adam BrownSenior Systems AdminCommented:
No. The users only need to be licensed for the rule to apply to their messages. You may also need to have your own mailbox licensed for the rules to show up. Check the settings in Azure Information Protection through the azure portal (portal.azure.com) and make sure the settings haven't been monkeyed with. If you haven't disabled and re-enabled AIP on your tenant, you may want to try that as well.
FrogworksAuthor Commented:
I did adjust the settings when trying to initially set things up (following an article by MS), and I have tried to deactivate and then reactivate AIP.

Is there a way to reset the entire tenant to default and start from scratch to ensure I didn't do something wrong?
FrogworksAuthor Commented:
This appeared to be an error on the MS side that they have not been able to correct thus far. We are working with them to resolve.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Encryption

From novice to tech pro — start learning today.