Disable Hybrid enabled hosted archive mailbox

We incorrectly enabled an Archive mailbox for a cloud user, we are in a hybrid setup.  It was enabled via O365 portal and not on-prem as a hosted Archive Service first.

Now when we try to disable it online, we have to Disable In-Place Archive and get this error:

Exchange cant disable the mailbox <mailboxname> because it is on in-place hold. ComplianceTagHolderApplied: false, DelayHoldApplied: false, OrganizationalPolicies Applied: mbxjkldjlky539sm4kje3ds42jh509so8dlk3:2, UserPolicies Applied: . For more information, please see the powershell cmdlets, Get-OrganizationConfig <> | fl inplace*, and Get-Mailbox <> | FL

Get-Mailbox <mailboxname> | FL *archive*
ArchiveDatabase             : NAMPR03HSD34-db099
ArchiveGuid                 : 65d78ae3-dc7b-61e9-475b-97ad31a8f74d
ArchiveName                 : {}
JournalArchiveAddress       :
ArchiveQuota                : 110 GB (118,111,600,640 bytes)
ArchiveWarningQuota         : 100 GB (107,374,182,400 bytes)
ArchiveDomain               :
ArchiveStatus               : Active
ArchiveState                : Local
AutoExpandingArchiveEnabled : True
DisabledArchiveDatabase     :
DisabledArchiveGuid         : 00000000-0000-0000-0000-000000000000
ArchiveRelease              :

Ive tried to disable the hosted archive on prem, then synced to the cloud, even tried clearing the msExchArchiveStatus attribute and syncing... We just cant seem to revert this so that we can enable it the right way, via Exchange On-Prem.
Christian HansUndecided... Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Vasil Michev (MVP)Commented:
Generally speaking, the attribute you need to adjust on-premises is the msExchRemoteRecipientType one. However, you also need to remove the hold from this mailbox in O365, which seems to be and org-wide one (so run Get-OrganizationConfig | fl InPlaceHolds)
Christian HansUndecided... Author Commented:
Hey. Yes. I saw your blog on the recipienttype and cleared that field in AD on prem. Forced a sync. No change. I can't seem to find where the mailbox is set to inplace hold though. Not in the security and compliance center.
FOXActive Directory/Exchange EngineerCommented:
christian did you trying running the below command in powershell connected to o365

Set-Mailbox –Identity "emailaddressofmailbox" -LitigationHoldEnabled $false

ref link:  https://community.spiceworks.com/topic/2162698-exchange-online-remove-phantom-in-place-hold
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

Vasil Michev (MVP)Commented:
Should be in the SCC, a retention/compliance hold that's configure for all of Exchange (not the individual mailbox). You can actually see the guid of the hold above, you can run a search via Get-HoldCompliancePolicy.

Get-HoldCompliancePolicy jkldjlky539sm4kje3ds42jh509so8dlk3

Open in new window

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Christian HansUndecided... Author Commented:
Got it Vasil, when running the Get-HoldCompliancePolicy we do have a  Exchange mail policy that applies to all users.
This was set up in https://protection.office.com/retention to hold mail for 7 years. So that's the issue.

So I guess the only way to remedy this would be to exclude the user mailbox from that policy, try to disable or remove the -Archive mailbox or disable the In-Place Hold on the mailbox, then add it back to the 7 year retention policy, and enable the Remote Hosted Archive on-premises again.
Vasil Michev (MVP)Commented:
Yup, that seems about right.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Powershell

From novice to tech pro — start learning today.