VM VirtualBox: Guest additions won't install

Hi
I'm trying to test weather Visual Studio Code - Code Editing. Redefined with the Excel Viewer - Visual Studio Marketplace plugin will work under fedora 12  stand alone (No Internet)

I have a fedora 17 running in a VM VirtualBox at home, I know it's the wrong version, but I figured it would be close enough for this test
having tried to install visualstudio code on the stand alone I know it has dependencies  See Here

unfortunately the Firefox  version wont load the above links, Nor experts-exchange.com, I keep getting connection reset errors other pages load like google and stackoverflow

The Guest additions won't install either so I can't access drives on the host machine, a USB drive nor shared clipboard etc
I get error
Guest additions: Kernel headers not found for target kernel 

Open in new window

fedora.JPG
Tried to run
yum update kernel

Error: Cannot retrieve metalink for repository fedora. 

Open in new window



Any Suggestions?
LVL 1
trevor1940Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Martyn SpencerSoftware Developer / Linux System Administrator / Managing DirectorCommented:
You actually need to install the kernel-headers package. This should be enough.
RAFAIT CONSULTANTCommented:
Hello

please check the following link:

https://www.tecmint.com/install-virtualbox-guest-additions-in-centos-rhel-fedora/

I remain attentive to your comments.
nociSoftware EngineerCommented:
The guest additions actually compile some kernel drivers.
To be able to do that it needs the kernel-headers installed. (and compiler etc. those probably are already installed, if not you will get a warning about it).

yum update
yum install kernel-headers

Open in new window


should do that.
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

trevor1940Author Commented:
I tried both your suggestions
I'm still getting this error both times

Error: Cannot retrieve metalink for repository fedora. 

Open in new window


@RAFA step of your link  "yum -y install epel-release"
@noci  "yum update"
trevor1940Author Commented:
Tried to follow the suggestions here still got same error

Not totally sure if I'm editing the correct file or line

Wondering if it'll be simpler to DL a working VM, ?

16 on
this page is the only 1 with  Guest Additions Installed but when I tried to run it crashed with memory issues
trevor1940Author Commented:
I wasn't able to get anything but a fedora 19 to work in a VM
so I booted and old pc in Fedora 12 of a live CD
I mentioned  visualstudio code  has dependencies it turns out the dependencies  have dependencies  some of which are not available for   Fedora 12

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nociSoftware EngineerCommented:
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.