IE11 does not have option for IE11 document mode (under Emulation) only 10 and Edge on Windows 7!

Laszlo Denes
Laszlo Denes used Ask the Experts™
on
Hello Everyone and thank you very much in advance for your timely and precise feedback/input/insights, etc. :-)
Came upon an odd issue due to a website browser requirement by one of our vendors. They need IE11 and it must not run in compatibility mode.
We use Windows 7 (Build 7601 SP1) and IE11 (Version 11.0.9600.19236, Update Version 11.0.105 KB4480965) on our desktops in a FFL/DFL 2012R2 (2x 2016 DC) AD infrastructure.
Our GPO (Computers - nothing under Users) has a few websites listed to be used in compatibility mode (the setting "Use Policy List of Internet Explorer 7 Sites"), but those are older and not related to this new vendor and we do not force anything else into compatibility. On the end-user side there are no entries at all.
What is odd is that they asked me to verify the emulation settings (instructions below)
1) In an Internet Explorer window, press F12
2) A new window frame will appear with a black title bar and 7 tabs to choose from
3) Select ‘Emulation’
4) Under the ‘Mode’ column, the last item is ‘User agent string’. That will be the IE version your session is running. If the emulation is not Internet Explorer 11, contact your IT representative to explore options to allow your internet browser to be IE11

which I did and I noted that although we are using Windows 7 and IE11 the default document mode was set to IE10 and there was an EDGE option, but NO IE11 option in the drop-down box that could be set and this perplexes me. We are using Windows 7 (so no Edge) and IE11 (so no Edge).
 IE11 browser but no ie11 option for document mode
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
AlexSenior Infrastructure Analyst

Commented:
That's because you're already running IE11, windows 7 only has IE11 so you can't emulate what it's already running.

Author

Commented:
Okay update - I read that the EDGE option in this scenario (IE11 on W7) IS ACTUALLY IE11 since they had no renamed it yet.
See thread here : https://community.spiceworks.com/topic/2194566-ie11-document-compatibility-mode-why-edge-instead-of-11

So now my new question is how can I use a GPO to force ALL of our W7 IE11 machines to use the EDGE or IE11 as the default document mode emulator rather than 10 which is the default on almost all systems (above screenshot was from a test system)

Author

Commented:
Right thanks Alex and I just read that it was a naming issue on MS side so EDGE in that context implies IE11 but many of our systems have 10 set as the default so now I have to figure out how to use GPO to force all of them to use EDGE (or rather the falsely named EDGE which is actually IE11) LOL!
Announcing the Winners!

The results are in for the 15th Annual Expert Awards! Congratulations to the winners, and thank you to everyone who participated in the nominations. We are so grateful for the valuable contributions experts make on a daily basis. Click to read more about this year’s recipients!

Senior Infrastructure Analyst
Commented:
You need to use enterprise mode and then get it to use an XML file

https://www.microsoft.com/en-us/download/details.aspx?id=49974

That can generate your XML file

Author

Commented:
thank you :-)

Author

Commented:
got it.... thanks...

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial