We help IT Professionals succeed at work.

How to get Firefox to stop prompting for username and password when accessing local SSRS reports.

Medium Priority
146 Views
Last Modified: 2019-04-15
Using Firefox I still get asked for username and password after saving username and password when trying to access local SSRS reports. I can see the credentials on the passwords and security section. I am running the latest version of Firefox and we do have an SSL certificate.
Comment
Watch Question

Dr. KlahnPrincipal Software Engineer
CERTIFIED EXPERT

Commented:
Is Private Browsing disabled in Firefox?
rwheeler23President

Author

Commented:
Under Options->Privacy & Security->History the one settings I see are
Remember History
Never Remember History
Use Custom Settings for History

This is getting frustrating because Firefox keeps upgrading itself and when I search the internet for solutions it finds older versions and the options are all moved around.
Jackie Man IT Manager
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
Have you enabled "Delete cookies and site data when Firefox is closed" under "Cookies and Site Data"?
rwheeler23President

Author

Commented:
"In permanent private browsing mode, cookies and site data will always be cleared when Firefox is closed" is what the setting is telling me. So the option is on and dim.
Jackie Man IT Manager
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
Firefox -> History
1. Goto about:preferences#privacy

2. Under "History", uncheck "Always use private browsing mode"

3. Restart Firefox
rwheeler23President

Author

Commented:
Ok, I have unchecked Always use Private browsing mode and clicked Clear History when Firefox closes and I still get prompted. These credentials are in the password list and the pop box does appear with the proper credentials.
Jackie Man IT Manager
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
1. From a browser window, navigate to about:config.
Click I’ll be careful, I promise! to accept the security warning.
2. In the Search field, enter network.negotiate.
3. Double-click the network.negotiate-auth.trusted-uris Preference Name, enter http://hostname.example.com, in the Enter string value field, and then click OK.
Note: The values in the Enter string value field are comma-separated.

Source: https://documentation.sas.com/?docsetId=bimtag&docsetTarget=p1871e69gmwdr0n1o182krslc10p.htm&docsetVersion=9.4&locale=en#n0i1jt8gce0a99n1p3s2k4w72zcx

Reference:
https://www.gpug.com/blogs/aaron-back/2015/03/27/accessing-ssrs-report-manager-site-in-firefox-browser
rwheeler23President

Author

Commented:
I give up. Thanks for all your tips but I will live with the popup box. I have tried all these suggestions and nothing works. IE11 works just fine for SSRS and never asks for credentials.