1 Gigabit NIC gets 10Mbps connection speed

Network Adapter Card SpeedHi,
 I have a desktop PC where network adapter card shows 10.0Mbps, but network card is capable of 1Gbps.
 It is currently connected to  Linksys LRT215 Gigabit VPN router.
 Strange enough, when I connect this computer to a Ubiquiti Networks 48-Port Gigabit UniFi Switch (Part#: US-48-500W), there is NO LIGHT lit on the switch. But all the workstation PCs and other PoE devices are connected to this Ubiquiti and every single connected port shows link and activity light.
So I have no choice but to connect to Linksys LRT215 Gigabit VPN router. Linksys is daisy chained to Ubiquiti Switch.

Can you help?
LVL 1
sgleeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

CompProbSolvCommented:
I had a similar problem on two PCs (same model of Dell) after a Windows 10 update.  I never was able to resolve it, even after many different driver changes and several different switches.  Occasionally it would connect at 1G, but most of the time it was 10M.  I eventually added a NIC.

Try different drivers from Realtek, Microsoft, and the computer manufacturer.  If that resolves it, you'll want to look into ensuring that the driver doesn't get "updated".

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sgleeAuthor Commented:
ok. I will try that this afternoon and report back.
nociSoftware EngineerCommented:
Disabling AUTO negotiate,  and set fixed settings might help. (set same speed, and also both on FDX or both ends on HDX).
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

sgleeAuthor Commented:
Noci
Where can I change these settings?
CompProbSolvCommented:
On the status screen you posted above, select Properties, Configure, Advanced.

You'll find a number of entries there.  The most likely one you'll want is Speed & Duplex.  Depending on the actual driver used, there may not be a setting for Gigabit.  In that case, you'll only get it with Auto.

It may be useful to change it to 100M and see if that works at all.
nociSoftware EngineerCommented:
And also you need to do this on the router. (should be a setting on the LAN Interface there)
Coolie SheppardSystems EngineerCommented:
So I had this happen on a production server before. Checked the ports, card, drivers, etc.

You know what it came down to?  A bad cable.

Sometimes we can overlook the little things.

Try a different cable and see if the issue remains
David FavorLinux/LXD/WordPress/Hosting SavantCommented:
Click on details to see if speed is set to fixed 10 Mbps.

If it is, likely you can change this to auto negotiate, or your actual router speed, to fix the problem
sgleeAuthor Commented:
Tech support suggested that I re-install  MB driver, but to no avail. I also tried different Ethernet cables.

I took the computer home, added an used NIC and it works fine.

It is not worth spending time any more on this issue.

Thank you for your help.
David FavorLinux/LXD/WordPress/Hosting SavantCommented:
Likely all the relevant info is under the Details tab, which is currently collapsed.

Like settings for Duplex + Negotiate type.

All these details are required to take a guess at a fix.
sgleeAuthor Commented:
I  added a new NIC and it works fine.
Thank you for your suggestions.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Switch

From novice to tech pro — start learning today.