Link to home
Start Free TrialLog in
Avatar of Edgar Cole
Edgar ColeFlag for United States of America

asked on

My downloads are failing!

I'm suddenly having problems downloading files. I've tried both Firefox and Chrome. The following is an example of the error I'm getting from the Chrome browser:

User generated image
The onset of the problem seems to coincide with a recent Windows update. That's pure speculation, of course, but it's the only thing I can think of that has changed on the system.
Avatar of Adam Brown
Adam Brown
Flag of United States of America image

Try two things...
1. Look at your browser's settings for where to save downloads, make sure you have permission to save there
2. Run the browser as an administrator
Also, what is driver booster set?  That is not part of Windows.   Did you install some 3rd party software and has that broken some part of Windows as a result of the upgrade.
Updates usually do not reinforce security at your file system, but might do occasionally. Check the configured download folder for permissions.
Please don't run your browser as administrator (elevated) - this can be done once for testing, but cannot be a solution. It's just too dangerous for normal use that way.
Avatar of ☠ MASQ ☠
☠ MASQ ☠

Check if you can get rid of the error in Chrome by changing the location downloaded files are saved to.

https://support.google.com/chrome/answer/95759?co=GENIE.Platform%3DDesktop&oco=0
could your firewall/anti-virus software be blocking .exe files?

can you download other file types (.pdf, etc...)?
driver booster set?? that does not sound like a safe file to download, I heard it is usually bundled with PUPs..... potentially unwanted programs.... and the application itself is some what questionable. Anysoftware from IoBit is questionable.
Avatar of Edgar Cole

ASKER

The saga continues. Here is the latest.

I took a look at my Downloads folder, where stuff has been accumulating for many years. Most of it I didn't recognize, and none of it was indispensable. Besides, the entire folder is backed up on a daily basis. So, I cleaned out the Downloads folder.

When I tried downloading another file, it failed again, but this time I got a message I hadn't seen before:

User generated image
I'm not sure what this means, and why it contains the "network location" reference. My Downloads folder is on the local drive.

I also found this…

User generated image
By the way, the answer is that I cannot download files of any type to the Downloads folder, but I can download to other locations.
Either directly or indirectly this sounds like your security software blocking access.  Both these issues could be caused by real-time file system protection from AV or Anti-Malware software.  It may be that the settings are overly secure (maybe due to an update) or there is an active infection.  Which AV/Anti-Malware solutions are you using? Are you able to temporarily disable real-time protection on it and try a download from a known safe site?  Real-Time protection can also block access to removable media such as your card reader.
i would start by looking at the installed softwares list, and uninstall driver booster + other softwares that are not needed; if unsure, post a screenshot of these softwares, so we can suggest some
it can also be you have malware - so run mbam : https://nl.malwarebytes.com/

imo you have 2 choices : troubleshoot or do a fresh install
since you did not mention the pc model on which this happens, nor the OS and version, it is difficult to suggest proper options
Probably -for some reason - the Downloads folders requires permissions that are missing...take a look at one of the folders that you can download and cross check the Security tab (Folder --> Right Click --> Properties -->Security)
this is what my  Downloads folder Share properties look like on my PC:User generated image
as nothing appears in your Share property, click on the Share button and add your name from the list by clicking the down arrow near the top
YOu don't need to share the downloads folder.
right click on the downloads folder and check the properties, make sure the path is  C:\users\(your user name)\downloads.
My computer is a Dell Mobile Precision  M4700, running Windows 10 Professional, version 1809.

I've been running Malwarebytes for over a year and 1/2. It's configured to run a scan every day. A few days ago, I noticed that it had quarantined a few files, including some from the Downloads directory. Attempting a download with Malwarebytes disabled hasn't helped.

As a test, I tried downloading a file while running the Chrome browser as Administrator, and it worked. Obviously, that's not a permanent solution.

While reflecting on recent events that might have contributed to this problem, I suspected that a recent Windows update could be the culprit. Of course it wouldn't be unreasonable to suspect malware. In addition to those, something else occurred to me. Recently I installed the Revo Uninstaller application. I did so on the recommendation of a vendor that was trying to help me resolve an issue. If you allow it, that program will make changes to the Windows registry – always a risky endeavor. Nevertheless, on at least one occasion I elected to do so. According to the Revo UnInstaller log, I've used it 3 times, the last of which was on the 11th of April.

I maintain thirty days of disk images. At this point I'm thinking it might be prudent to restore one of those images. I first started noticing the download problem within the last few days, so I'm thinking that restoring a backup from 10 to 14 days ago should be sufficient.
Driver set is part of I/O bit utilities.  Some malware detectors identify it as a PUP, but its not malicious, just annoying for some folks (constant requests to upgrade to paid versions).   I would focus on permissions on the windows download folder.   Make sure each listed user/group has the Allow column checked for each option (except "special permissions").   And make sure to tick the replace child objects permissions.  

Windows updates can have a habit of messing with security settings from time to time.
I would suggest, first just see if you can create a simple txt file in the downloads directory, if so, see if you can delete a file.  If so, then it's very likely that your Revo did change permissions, or even Mbytes, on the download folder and that your browser is limited in it's permissions.  If you check the permissions properties of the folder, you may see an entry in there, this would be much simpler than restoring the drive to another image and taking the chance on losing something else you've done.
ASKER CERTIFIED SOLUTION
Avatar of Edgar Cole
Edgar Cole
Flag of United States of America image

Link to home
membership
This solution is only available to members.
To access this solution, you must be a member of Experts Exchange.
Start Free Trial