hard drives show up in bios, but not in windows

My computer started to give me blue screens for the first time yesterday, 3 times actually.  Today, same thing, I was able to get into windows, but it crashed 2 or 3 times, so I did a full restore from my backups about 4 hours ago, and so far so good, it has not crashed yet, BUT, my problem now is, besides my OS drive (SSD), I had 2 more drives in my PC, another 2.5" SSD and a 6TB drive, both already formatted.  
The bios sees both drives, but when I boot to windows, none show up.
I checked the device manager, nothing there, I checked disk management, they are not there.  I clicked on scan for new hardware in device manager, nothing shows up.
I found online to run the windows memory diagnostic tool, did that, restarted, and still didn't' show up.   I'm a bit puzzled.

Any other thoughts why the drives show up in bios, but not in windows, running the latest version of windows 10.

device manager
disk management
DanNetwork EngineerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnBusiness Consultant (Owner)Commented:
hard drives show up in bios, but not in windows
besides my OS drive (SSD)

Does your OS drive show up in BIOS?  

Can you start with a bootable USB Key, and then see any folders on the OS drive?
DanNetwork EngineerAuthor Commented:
Yes, yes all my drives show up in the bios.
So my bios setting is set to legacy, this will allow my OS drive to boot.
If I change the setting to UEFI, my OS won't boot.

I haven't tried that, so what's the easiest or fastest way to make a bootable usb?  Well, does it matter, as with legacy mode, I can boot into my system, that's no problem, it's just not displaying my other 2 drives, my 2nd SSD and platter drive, which has data on it.
Lee W, MVPTechnology and Business Process AdvisorCommented:
Easy.  You don't have the Intel Chipset drivers installed.  Look at Device Manager under Storage Controllers - You have Exclamations next to the Intel C600... devices.  If it's not a driver issue, then it's possible the device is bad... I'd start by installing the chipset drivers for the mainboard as that will probably restore access to the drives.
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

David Johnson, CD, MVPRetiredCommented:
once you insert media into the device it will get a drive letter
JohnBusiness Consultant (Owner)Commented:
And after those update, UEFI should work also
Robert RComputer Service TechnicianCommented:
I was almost tempted to say maybe they were accidentally unplugged either the power or the signal cable, but when you said they were detected in the bios that obvious is not the case. I still feel it is a hardware issue. I would create a bootable usb stick from the Ultimate boot disk.
and run diagnostics on the system. You can create a bootable usb stick using the rufus tool that creates a bootable disk on a usb stick from an iso file    https://www.techspot.com/downloads/6062-rufus.html

Download the ISO from: https://www.ultimatebootcd.com/
DanNetwork EngineerAuthor Commented:
installed the intel chipset drivers and restarted, still the same, said the newest or best driver is already installed.
Drives still do not show up.

I made the boot disk, I will try that.  It's late, so I might try to continue working on this tomorrow.
JohnBusiness Consultant (Owner)Commented:
Try also updating the BIOS on the machine.

Also, as asked earlier, boot with a bootable USB key and see if the drives and folders show up this way.
DanNetwork EngineerAuthor Commented:
So I made a bootable Ian with grub, I booted to it, but now I have no idea how to use it?  I'm starting at a prompt:  grub> _

I pressed tab, so I got a list of all these commands, but no idea how to use it, I guess I need to google it
JohnBusiness Consultant (Owner)Commented:
Use LS   LS /?   for help.   Use this to list files on the drives.
DanNetwork EngineerAuthor Commented:
I did ls, and it says:
Grldr autorun.inf autorun.ico system\ volune\ Information

The I did ls/?
Error: no such command: ls/?
JohnBusiness Consultant (Owner)Commented:
Maybe try a Knoppix USB key.  I am not sure about Grub commands.
Lee W, MVPTechnology and Business Process AdvisorCommented:
If you want to access the drives to recover data, you can try Linux.  If you want to get them working under Windows you need to resolve the controller driver issue.  You could also look into attaching with USB adapters or switching the SATA ports you're connected to.  You MIGHT get away with changing the mode of the SATA ports (if they are in RAID take them out of RAID if that's an option) but be WARNED - doing so could make it even harder to access the drives / recover the data.
DanNetwork EngineerAuthor Commented:
Thanks Lee, I'll remove the drives tomorrow and backup the data, I know I can access the data, I guess after I get the data off, them I'll try again changing the settings in the bios to make them show up.  

It's just crazy as it worked earlier today, since the computer want booting under ufei mode, we changed it to legacy mode and it boots,  but both drives don't show up now in windows.
DanNetwork EngineerAuthor Commented:
I wonder is this had anything to do with it, but during the restore, I used arcserve udp backup, Nate metal restore, during the restore it was giving me a hard time selecting my OS drive, :9 I shut down the computer, unplugged my 2 drives and performed the restore.  Then did the restore and the OS drive wouldn't boot, bios was set to uefi, so I changed that to legacy and it boot fine.

Is it a possibility that the drives are not showing up because my MBR or bootrec file is corrupt?
They are not boot drives, so didn't think it would make a difference.
Lee W, MVPTechnology and Business Process AdvisorCommented:
Have you resolved the device manager error yet?  Can you verify what the exclamation is for if it's still there?

https://downloadcenter.intel.com/product/98463/Intel-C600-Series-Chipsets
nobusCommented:
the fact that you did a full restore ( an image restore, yes?) - and have errors in Device manager, shows to me that you have probably hardware problems - that should be sthe start of your problems
i would run diagnostics on ram AND disk - manufacturer's tools; i use the UBCD for this
Hardware diagnostic CD    UBCD
---------------------------------------------------
go to the download page, scroll down to the mirror section, and  click on a mirror to start the download
Download the UBCD and make the cd   <<==on a WORKING PC, and boot the problem PC from it
Here 2 links, one to the general site, and a direct link to the download

since the downloaded file is an ISO file, eg ubcd527.iso - so you need to use an ISO burning tool
if you don't have that software, install cdburnerXP : http://cdburnerxp.se/

If you want also the Ram tested - run memtest86+ at least 1 full pass,  - you should have NO errors!
direct download :  http://www.memtest.org/
 
For disk Diagnostics run the disk diag for your disk brand (eg seagate diag for seagate drive)  from the HDD section -  long or advanced diag !  (runs at least for30 minutes)

http://www.ultimatebootcd.com/      

**  you can make a bootable cd - or bootable usb stick
*** note *** for SSD drives  use the tool from the manufacturer, like intel 's toolbox :
https://downloadcenter.intel.com/download/18455/Intel-Solid-State-Drive-Toolbox

for completeness -here's how i handle disk problems : http://www.experts-exchange.com/Storage/Hard_Drives/A_3000-The-bad-hard-disk-problem.html

==>>****in order to be able to  boot from CD or usb - you may have to disable secure boot in the bios
Robert RComputer Service TechnicianCommented:
Can both drives can be read in another system? Or how about putting the drives in a hard drive dock and access them via usb?  When plugging in the drives did you ensure both cables were snuggly plugged into the drive?
David Johnson, CD, MVPRetiredCommented:
What the author has presented is fairly common with multimedia cards. It will show the device but it will also say NO MEDIA INSERTED. If you insert formatted media it will the show as a drive and be assigned as a drive letter.  My Epson Printer AND a USB Dongle that I own have various multimedia slots i.e. SD, miniSD x 2, MicroSD and with NO media plugged into the device the device shows up and is also available in disk management but no drive letter is assigned UNTIL I put some media into the slot.  Then it shows up, this is situation normal since as far back as VISTA (can't remember further back)
nobusCommented:
also if drives are seen by BIOS and not by Windows, you may need to give them a drive letter
David Johnson, CD, MVPRetiredCommented:
since there is NO media inserted there is nothing to give a drive letter to
Robert RComputer Service TechnicianCommented:
The problem is it is not shown in the disk management or device manager as a device available so you cant assign a letter to a drive that windows does not see in the first place.  But that is probably because the storage controller drivers dont have the proper drivers... as Lee has mentioned a couple times in this post that the proper controller drivers need to be installed once the proper drivers are installed then other drives will be detected.  If windows does not install them because it says the best driver is already installed, don't use the windows search for best driver tools in windows just download and install the drivers, if they will not install deleting the device in device manager and then use to latest chipset drivers to do the install.  Then reboot the machine.
storage controller
fred hakimRetired ITCommented:
You may have better (and easier to use) troubleshooting options with a LazeSoft Suite boot USB.   Download Lazesoft, install it and create the USB.  (you select from multiple boot modes).   Lazesoft includes a Disk/Partition manager, among a number of other useful capabilities, including File explorer, Disk clone, partition copy etc.  

See:  https://www.lazesoft.com

You can select a matching windows PE for the USB to boot.
David Johnson, CD, MVPRetiredCommented:
put an SD Card or micro SD card into one of the slots of the media reader and report back

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
DanNetwork EngineerAuthor Commented:
I just updated the bios and the chipset, and still the same issue, the same icons still there, with the yellow exclimation point.
I tried with both drivers the drivers directly from Intel, and also the drivers from Dell, restarted and still doesn't see the drivers.

I know the drivers are formatted ok, as before the system restore, they both worked fine and had data on them, they are formatted as NTFS.

David, so you're saying just use an SD card or micro SD into my slot, I'll try to find one, but I don't think I have any.

best
DanNetwork EngineerAuthor Commented:
You gotta love windows, so it tells me the best drivers are already installed, but that's not true.

After attempting to search manually and trying different things, I figured out a way to find the drivers I downloaded and tried to manually install them, and after a few tries, even through it kept on telling me I'm using the best drivers, I got the drivers to load, and guess what, then windows recognized the drivers, I didn't even have to go to device or disk management, they just appeared automatically.

Thanks again guys for the help!!!!
DanNetwork EngineerAuthor Commented:
Thanks again everyone for your help!!!!!
JohnBusiness Consultant (Owner)Commented:
You are very welcome and I was happy to help
David Johnson, CD, MVPRetiredCommented:
It's what I've been saying for the longest time. It has to have media to continue
Robert RComputer Service TechnicianCommented:
yeah I hate when Windows say the best drivers are already installed when the drivers installed give error messages. Sometimes the best way to install it manually is in safemode. But yes they would still have to be installed manually. Glad you got it worked out.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows 10

From novice to tech pro — start learning today.