Hyper-V VM Stuck in saved State and wont boot

I am running Hyper-V  on Svr 2012 R2.
I rebooted the host after installing visual c++ 2015 Redistributable.

when it came back up i saw my VMs stuck in a "Saved" state.
when i try to start the VMs i get the error
"An error occurred while attempting to change the state of virtual machine"
"'Hostname' failed to initialize.

I tried deleting the saved state, but got the same error as noted above.

i check the event viewer and see event IDs 14070 and 15120.


I am also getting error with event ID 1000 as shown below.
Log Name:      Application
Source:        Application Error
Date:          5/13/2019 2:39:48 PM
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      HYPERV-HOST.MYDOMAIN
Description:
Faulting application name: vmwp.exe, version: 6.3.9600.19227, time stamp: 0x5c0b5147
Faulting module name: KERNELBASE.dll, version: 6.3.9600.19269, time stamp: 0x5c5e079f
Exception code: 0xe06d7363
Fault offset: 0x0000000000008e6c
Faulting process id: 0x10e4
Faulting application start time: 0x01d509c39fdc6f46
Faulting application path: C:\Windows\System32\vmwp.exe
Faulting module path: C:\Windows\system32\KERNELBASE.dll
Report Id: ddda0b19-75b6-11e9-80bb-4cd98f608fa5
Faulting package full name:
Faulting package-relative application ID:
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2019-05-13T19:39:48.000000000Z" />
    <EventRecordID>22443</EventRecordID>
    <Channel>Application</Channel>
    <Computer>HGSJAMDLPHOST.HGSJAMAICA.COM</Computer>
    <Security />
  </System>
  <EventData>
    <Data>vmwp.exe</Data>
    <Data>6.3.9600.19227</Data>
    <Data>5c0b5147</Data>
    <Data>KERNELBASE.dll</Data>
    <Data>6.3.9600.19269</Data>
    <Data>5c5e079f</Data>
    <Data>e06d7363</Data>
    <Data>0000000000008e6c</Data>
    <Data>10e4</Data>
    <Data>01d509c39fdc6f46</Data>
    <Data>C:\Windows\System32\vmwp.exe</Data>
    <Data>C:\Windows\system32\KERNELBASE.dll</Data>
    <Data>ddda0b19-75b6-11e9-80bb-4cd98f608fa5</Data>
    <Data>
    </Data>
    <Data>
    </Data>
  </EventData>
</Event>
Top DocSystems AdministratorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Question: What was the C++ being installed for?
Marc Lester MartinIT SpecialistCommented:
Try to uninstall the last application that you installed. Maybe it's just a coincidence, try to check the server's RAM, storage, drivers, etc. There's no harm to check if virtualization was turned off from the BIOS for some reason.
Top DocSystems AdministratorAuthor Commented:
@Philip -
Was needed to install a third party application.

@Marc -
Did all that was suggested, issue still remains.
Fundamentals of JavaScript

Learn the fundamentals of the popular programming language JavaScript so that you can explore the realm of web development.

Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Top Doc,

Nothing should be installed on the Hyper-V host. Nothing at all but the role.

Installing a third party product means the host is now requiring its own dedicated Server license plus the integrity of the host may be compromised as was noticed here.

Please remove the third party product and put it in a guest VM where it belongs.

I have two very thorough EE articles on all things Hyper-V:

Some Hyper-V Hardware and Software Best Practices
Practical Hyper-V Performance Expectations
Top DocSystems AdministratorAuthor Commented:
@Philip -
My server is already compliant with all the stipulations you have highlighted here.
This Third part software was simply a management application from the manufacturer of the server.

The problem still persists.
Trying to rule out reloading the OS and starting from scratch.
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
10-4. Okay, got it. What vendor/manufacturer?

Is the server set up with two partitions? One for the host and one for the guests?

If yes, then a reload is actually quite quick. This is what we do with all of our servers:
Disaster Preparedness: KVM/IP + USB Flash = Recovery. Here’s a Guide

Once the host is set up and good to go importing the existing VMs takes a few minutes.
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Sorry, got stuck on the host side.

The VMs are backed up?

The process is simple:
 + 1: Set up a new VM using the existing VHDX file(s).
 + 2: Boot the VM and reconfigure the network setup
 + 3: Reboot the VM if necessary
 + 4: Wash, rinse, repeat.

EDIT: Make sure _all_ VMs are set to "Shut down" in their properties. Don't leave the default "Save" as that does leave room for issues.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Top DocSystems AdministratorAuthor Commented:
@Philip

Reloading the OS on the host worked in getting the VMs back up.
once the host was reloaded the steps were simple as you had listed.
 + 1: Set up a new VM using the existing VHDX file(s).
 + 2: Boot the VM and reconfigure the network setup
 + 3: Reboot the VM if necessary
 + 4: Wash, rinse, repeat.

10-4. Okay, got it. What vendor/manufacturer? - Dell.
Philip ElderTechnical Architect - HA/Compute/StorageCommented:
Suweet! :D
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
server 2012 r

From novice to tech pro — start learning today.