External email not showing up in mailbox

bensonwalker
bensonwalker used Ask the Experts™
on
We have a ESXI 6.5 host whose Time got out of sync. I was able to fix that by setting the NTP servers and manually adjusting the Primary Domain controller's date and time. However, Exchange 2010 is now not receiving emails from outside the network. Our barracuda shows them as being delivered but my test email hasn't arrived in the mailbox.

Sending email goes out no problem.

Is there something i need to check/reset or do i need to give it time to get past the time gap? It was about 1:15am tomorrow (5/14) before i got it fixed...maybe this is a bit optimistic?

any help/suggestions are appreciated!
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
timgreen7077Exchange Engineer
Distinguished Expert 2018

Commented:
check the hub transport queue to see if any emails are being stuck in the queue and not being delivered to the mailbox and also verify that the time is aligned with the time in AD.

Author

Commented:
I don't see messages in the queue. Went through the exchange management console < toolbox < queue viewer

I'm also not sure what you mean by "the time is aligned with the time in AD" The PDC and the Exchange server show the same time down to the second...the exchange server clock also updated when i set the correct time on the PDC.
timgreen7077Exchange Engineer
Distinguished Expert 2018

Commented:
check OWA also and verify your test disnt come through. also make sure all exchange services are running.
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
I've been testing through OWA. Sending works. All services are running and were just restarted. still not receiving my test email.
timgreen7077Exchange Engineer
Distinguished Expert 2018

Commented:
you need to check your barracuda then. also you didnt make changes to the receive connectors did you?

Author

Commented:
Barracuda is showing as delivered. No changes made to the receive connectors that i'm aware of.

I did just run a connectivity test for inbound SMTP which failed because "Testing TCP port 25 on host msrecord.domain.com to ensure it's listening and open"
timgreen7077Exchange Engineer
Distinguished Expert 2018

Commented:
is your MX record pointing to the barracuda or some thing else?

Author

Commented:
MX is pointing to barracuda as the highest priority. We also have a sonicwall in place. i just restarted the sonicwall.

But none of this was touched or changed. The only thing that changed today was the 3-4 hour glitch in server time.
timgreen7077Exchange Engineer
Distinguished Expert 2018

Commented:
do a message tracking in exchange and see if it shows a email delivered, if not I would focus on the barracuda

Author

Commented:
Barracuda is delivering to other exchange servers without an issue. It's a specific client exchange server.

message tracking isn't showing anything.
Exchange Engineer
Distinguished Expert 2018
Commented:
If you can remove that client from the list of servers the barracuda sends to that is what i would suggest. Then reboot that server and see if that helps it.
Distinguished Expert 2018

Commented:
Check available disk space on the server.

Author

Commented:
Tim, thank you. I'm not sure how/why/what happened with the barracuda destination server but it was incorrect. As soon as i changed it to the correct IP mail started showing up. Baffling but at least it's resolved.

masnrock, disk space is good. I did check that. Thank you.
timgreen7077Exchange Engineer
Distinguished Expert 2018

Commented:
Great

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial