Do you know how I can disable the toggling of the num lock key on Wondows 2012 R2?

I have a  vSphere Client 5.5 with a Windows Server 2012 R2 and as a guest VM. The funny thing is that the num lock key set to ON when I move the cursor into the VM. When I move it out it willl set my num to OFF.
Arnold SwanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

arnoldCommented:
Sounds as though the default setting on the workstation from which you connect using vsphere client, has num locks off.
Presumably you have vmtools installed on the VM, when you access the VM the keyboard is now reflecting the settings on the VM, locking the hum locks.

One is to set the VM nun lock to off or the other to on.

I.e. You have to be uniform. Your VM language is italian, while the workstation default language is english the keyboard will reflect the character mapping accordingly.
English when you are outside the vsphere client and Italian when you are in the VM.
Arnold SwanAuthor Commented:
This only happens when I am on the vSphere Client on the VM and the console tab. This is not happening when i RDC into my VM.
arnoldCommented:
ROc local keyboard keystrokes (num lock on/off is controlled by the local system)
Vsphere switches the keyboard behavior when active to mimic as though the keyboard is directly connected to the system.

I.e vsphere client to VM activates the mouse/keyboard using VMware tools as though the keyboard and mouse are directly connected ..

The vmtool installed means you need not release ctrl+alt the keyboard/mouse for use on local system.

What is the implication other than the number key light being on or off.

The keyboard functionality does not change when you are on the local system.

The default setting on most systems I use is num lock is on.

At times use mouse keys so num lock off, means numbers pad is used for mouse controls.
Arnold SwanAuthor Commented:
I just decide to not worry about. Since I downloaded the vmware tools.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
arnoldCommented:
Is it not what I suggested?
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Virtualization

From novice to tech pro — start learning today.