Access 2013 combo box wizard with a linked table getting error

rjef
rjef used Ask the Experts™
on
Access 2013 using combo box wizard with a linked table getting error  message 'no valid fields can be found'   See attachment
Linked-table-for-customer-combo-box.jpg
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
John TsioumprisSoftware & Systems Engineer

Commented:
Have you tried closing/ compacting & repairing
Dale FyeOwner, Dev-Soln LLC
Most Valuable Expert 2014
Top Expert 2010

Commented:
can you open the linked table and view records?

If not, your link may be bad, try refreshing those using the linked table manager.

You may have to delete those linked tables and link them again.
Jeffrey CoachmanMIS Liason
Most Valuable Expert 2012

Commented:
...or the table was deleted altogether.
Sometimes the Back end Developer will delete a table, ...not knowing that the Front end developer needs it for something...
;-)
This will generate the exact error you are getting...
Deleted source Table Error
Also:...
What type of linked tables are you using there?
In your screenshot, I only see the "Customer" field...
Many times you get errors like this if your table is missing a Primary Key.
John TsioumprisSoftware & Systems Engineer

Commented:
Am i wrong or this is a 3.5 months old question ?
Jeffrey CoachmanMIS Liason
Most Valuable Expert 2012

Commented:
yep...

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial