Netlogon and Windows time not starting automatically on SBS 2011

Ed Shnatter
Ed Shnatter used Ask the Experts™
on
We've been having problems with an SBS 2011 server recently.  People weren't getting the logon script to get the mapped drives, and if they tried to get to shares, they were prompted to login again (it's a domain).  Then they get the shares

After some troubleshooting, it was because NetLogon wasn't started.  We can manually start netlogon (which is set to automatic) and everything is fine... till a reboot and netlogon doesn't start.

Looking around for info on that issue, it talks of making sure it's set as a dependancy to Lanman server and lanman workstation.  and to make sure those are set to automatic.

Uh, I don't see those listed in services at all!

And running dcdiag for the netlogon issue, also pointed ot windows time service not started / the server not advertising as a valid time server.

Any thoughts on, most pressing - getting netlogon to start (and should lanman server and lanman workstation be in the list of services in computer management?

and maybe something to get me started with windows time?

I saw a batch script to help resolve that:

net stop w32time
 w32tm /unregister
 w32tm /register
 net start w32time

but now, after a reboot, I manually start netlogon successfully.  Then look and windows time is not in the server list.  

if I run w32tm /register, I get  windows time in the services list.  I change login from local account to local system account.  Then start it manually, I get error 1709 account specified for the service is different from the account specified for other services running in the same process.

Some googling gets me:  https://www.thewindowsclub.com/fix-error-1079-windows-time-windows-event-log-windows-firewall-services-fail-to-start

I change the log in to NT AUTHORITY\LocalService

Now when I try to start time I get:  error 1290 The service start failed since one or more services in the same process have an incompatible service SID type setting. A service with restricted service SID type can only coexist in the same process with other services with a restricted SID type. If the service SID type for this service was just configured, the hosting process must be restarted in order to start this service.

It's an old server / trying to get them to replace it. But I feel I should be able to keep this running?

Oh, we've moved to office 365 exchange and all the exchange services on the box are disabled.  that's about all I did on this sbs 2011 standard box to deal with not using exchange on this box.  That was months ago.  It's been working fine since then.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Distinguished Expert 2017

Commented:
Check event log to make sure there is no jrnl_wrap_error.

The fix is d4 burflags.

Author

Commented:
i didn't see jrnl_wrap_errors

any other suggestions?

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial