Unable to connect to ESXi 5.5 using VSphere Client 5.5

I am having issues connecting to ESXi 5.5 using Vpshere Client 5.5. I am able to ping the server and the DNS from my PC. However, I am failing my Test Management Network test. It will fail the DNS  and hostname.
Arnold SwanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Andrew Hancock (VMware vExpert / EE Fellow)VMware and Virtualization ConsultantCommented:
if you connect to the ESXi 5.5 server using https:// do you get the web page ?

can you connect via SSH ?
Arnold SwanAuthor Commented:
Hi Andrew - Yes, I am able to connect to the ESXi 5.5 server using https:// and I do get the web page. I am able to ssh using PuTTY and login. I am able to ping the server without any issues. Now when I try to run vShere Client I get a choice to either run or save the installer. Which ever choice I make I get the attached error.
PuTTY.jpg
VMware-vSphere.jpg
Arnold SwanAuthor Commented:
Andrew - I just tried logging in with VMware Workstation and was able to login. However, this version is not licensed. So I will still need to figure out why vSphere client is not working. I will keep trying to troubleshoot.
Your Guide to Achieving IT Business Success

The IT Service Excellence Tool Kit has best practices to keep your clients happy and business booming. Inside, you’ll find everything you need to increase client satisfaction and retention, become more competitive, and increase your overall success.

Andrew Hancock (VMware vExpert / EE Fellow)VMware and Virtualization ConsultantCommented:
Restart the Network Management Agents, failing that if that does not work, restart the server.

VMware Workstation ONLY needs to be licensed to run VMs! (not use as a client!) - but it is restricted as a client.

Also 5.5 is end of life, but make sure you download and install the last patch before they disappear!
Arnold SwanAuthor Commented:
For some strange reason VSphere started working and I was able to connect to my server. Prior to this I tried trouble shooting and testing the DNS and host name through ESXi. All test passed. Not sure what happend ed but thank s Andrew for your input.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Arnold SwanAuthor Commented:
As always thank you Andrew!!
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Server Hardware

From novice to tech pro — start learning today.