Why is my website home page still showing a former page?

RadioGeorge
RadioGeorge used Ask the Experts™
on
I think this is a simple one.

First things first: I have a couple of websites I built myself using Front Page. They are simple, and FrontPage got it done.

This past week, I had to change the home page of one of them temporarily. I replaced it with an edited version of the same page containing a note saying the regular site would be up shortly. It took me a couple of days to be able to replace the original page, which of course is named "index.htm" I replaced the edited version with the regular home page this morning.

But the EDITED version is still showing!

Thinking I might be losing my mind, I brought up the page in two different browsers other then my main one, Chrome, and the original  one which should be appearing did in fact appear just fine in Opera and Pale Moon.

Is this another dandy little thing that Chrome has perpetrated?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Scott FellDeveloper & EE Moderator
Fellow 2018
Most Valuable Expert 2013

Commented:
I think you answered your own question with your topic, browser caching. Clearing your cache or just using incognito will help.

In chrome, if you hit F12 to bring up the console, click on the network tab and view the "size" column. That will tell you if the page you are viewing is from cache or not.
RadioGeorgeOwner/Programmer

Author

Commented:
Please note that I am a fairly rank amateur coder!

I brought up the page, hit f12 and I do not see anyt "size" column on the page. In fact, I was very surprised to see very little coding with all that's on the page.

Does this help:


<iframe id="insticatorUserTrackingIframe" src="https://b2c.insticator.com/v4/pages/usertracking" style="display: none;"></iframe>
Most Valuable Expert 2017
Distinguished Expert 2018

Commented:
Try adding a parameter to the URL. For example

https://www.yoursite.com => https://www.yoursite.com?a=1

This will change the URL and circumvent any caching.

If this fixes the problem - it is the cache - if not then it is something else.
Success in ‘20 With a Profitable Pricing Strategy

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Scott FellDeveloper & EE Moderator
Fellow 2018
Most Valuable Expert 2013

Commented:
You may need to hit f12, then refresh your page.  For this EE page, I have done the same.

Capture.PNG
You can see where it shows memory cache or disk cache or a number representing if something loaded directly by the size.

Where are you getting the iframe code from? That looks like it is for tracking
David FavorFractional CTO
Distinguished Expert 2018

Commented:
Provide a clickable URL of the sites for testing.

Far easier to test + know, then guess.

You can also test this yourself using...

curl -I -L $URL

Open in new window


Looking at caching headers + MIME types for various assets (file types) returned by your site.
RadioGeorgeOwner/Programmer

Author

Commented:
David FavorFractional CTO
Distinguished Expert 2018

Commented:
Try forcing no caching of any text/html + text/plain MIME types, which might be cached by your browser.

In Apache, something like this...

<IfModule mod_expires.c>

      ExpiresActive On

      Header set Cache-Control "max-age=0, public, no-cache, no-store, must-revalidate" "expr=%{CONTENT_TYPE} =~ m#text/html#i"
      Header set Cache-Control "max-age=0, public, no-cache, no-store, must-revalidate" "expr=%{CONTENT_TYPE} =~ m#text/plain#i"

      Header set Pragma "no-cache" "expr=%{CONTENT_TYPE} =~ m#text/html#i"
      Header set Pragma "no-cache" "expr=%{CONTENT_TYPE} =~ m#text/plain#i"

      Header set Expires "Thu, 01 Jan 1970 00:00:00 GMT" "expr=%{CONTENT_TYPE} =~ m#text/html#i"
      Header set Expires "Thu, 01 Jan 1970 00:00:00 GMT" "expr=%{CONTENT_TYPE} =~ m#text/plain#i"

      ... ... ...

</IfModule>

Open in new window


This might effect your specific browser, as checking your returned headers, there's no forced MIME type cache expiration for text/html...

Your site...

mac> curl -I -L www.handicapping.com
HTTP/1.1 200 OK
Server: nginx/1.14.1
Date: Wed, 26 Jun 2019 00:41:20 GMT
Content-Type: text/html
Content-Length: 26133
Connection: keep-alive
Last-Modified: Mon, 13 May 2019 18:32:39 GMT
Accept-Ranges: bytes

Open in new window


A site with forced MIME type instant expiration...

imac> curl -I -L https://MoneySiteDoctor.com
HTTP/1.1 200 OK
Date: Wed, 26 Jun 2019 00:55:51 GMT
Server: Apache/2.4.39 (Ubuntu)
Strict-Transport-Security: max-age=63072000; preload
Upgrade: h2,h2c
Connection: Upgrade
Last-Modified: Fri, 31 May 2019 23:48:23 GMT
Accept-Ranges: bytes
Content-Length: 1442
Vary: Accept-Encoding
Cache-Control: max-age=0, public, no-cache, no-store, must-revalidate
Pragma: no-cache
Expires: Thu, 01 Jan 1970 00:00:00 GMT
X-Edge-Location: YUL
Content-Type: text/html; charset=UTF-8

Open in new window


Another note.

You're running NGINX also, so if you're using NGINX to front end Apache, then you may have caching issues between NGINX + Apache.

Keep this in mind, if you're running this type of setup.
RadioGeorgeOwner/Programmer

Author

Commented:
Experts: I did finally look at the size column on the network tab as suggested, and nothing I see makes any sense to me. I appreciate the detailed responses, but I am simply not technically advanced much beyond copy and paste, so I am totally lost as far as that info goes. Sorry to be so dense about this, but I am simply not a tech.

Anyone else have any suggestions? It's been three days now and the page I'm seeing on this computer in Chrome is still there. It is just fine on other computers and OK on this one with other browsers.
Developer & EE Moderator
Fellow 2018
Most Valuable Expert 2013
Commented:
Simply try clearing your cache for chrome https://support.google.com/accounts/answer/32050?co=GENIE.Platform%3DDesktop&hl=en

  1. On your computer, open Chrome.
  2. At the top right, click More More.
  3. Click More tools and then Clear browsing data.
  4. At the top, choose a time range. To delete everything, select All time.
  5. Next to "Cookies and other site data" and "Cached images and files," check the boxes.
  6. Click Clear data.

Note: you do have the option to select only specific things to clear. If you clear your saved passwords and you are the type that relies on the browser to save your passwords, you will be frustrated.  You may want to uncheck that option to keep your passwords.
RadioGeorgeOwner/Programmer

Author

Commented:
Thanks to all, and especially Scott. I have used EE a lot over the past five years and usually state my understanding and level of familiarity with parameters associated with my questions, but I guess I fall short in that area sometimes.

This solution was precisely what I was looking for and needed and it worked quickly and easily.

Having said that, I am still in the decision-making process of maybe changing from Chrome to a different browser, which started before this issue was posted on EE.

But I don't think I'll have to rely on an expert for that!

RadioGeorge

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial