Dell XPS 8500 won't use PC3-12800 RAM

CompProbSolv
CompProbSolv used Ask the Experts™
on
I have a Dell XPS 8500 with an i7-3770 whose motherboard was bricked by a Dell BIOS update.  I've since purchased another board, but am having problems with RAM.

The original board had PC3-12800 RAM modules.  From what I read, these modules (as well as the PC3-10600) should work.  When I put them in the replacement board, I get 4 beeps, indicating a RAM problem.  I've tried some Crucial brand RAM which was listed as compatible with this model and get the same results.  I've tried a single module in each of the slots, one at a time.

The board does work if I use a PC3-10600 module.

I've upgraded to the latest BIOS and reset it to defaults.  I don't see any settings in the BIOS that have anything to do with timing.

I can go ahead and purchase the slower RAM, but I'd prefer not to.

Is this board defective or am I missing something?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Commented:
By all logic, you are correct. The memory should've worked. And yes, DELL BIOS can be fully hidden if DELL chooses so for that model.
I would do a REALLY long burn in test with the working PC3-10600 memory module before proceeding to buy more of it. Because of this behavior it's showing now, it would really be a pity if you chose to buy the slower memory and find out the system is unstable a few days later. Invest time upfront, to determine if it's worth it to proceed with the slower memory upgrade.
Dr. KlahnPrincipal Software Engineer

Commented:
Not all memory is equal even though the speed specification for two modules may imply that it is.  CAS, RAS and (that third other timing which escapes me at the moment) may be significantly different for two supposedly identical sticks of memory.  A motherboard might be happy with 11-14-23 timing but refuse 10-13-26 timing even though the speed rating is identical.

Have a good close look at the timings on all your PC3-12800 modules and see if they are identical.
@Dr. Klahn
It's tough to look up the specs.  I haven't found any documentation from Dell about the motherboard requirements beyond the PC3-12800 spec.

The four modules that worked in the original board are all the same make and model (Nanya NT4GC64B8HG0NF-DI).  The specs I found indicate that they are CL11, but I'm not finding the other specs.  The new modules that I purchased that also don't work in the newer board (never tested in the older board) are also CL11.  

What I think is most relevant is that all four of these modules worked in one XPS 8500 board and none works in a different one (same power supply, same CPU).

This implies to me that there is a difference between the two boards that is the issue.
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Dr. KlahnPrincipal Software Engineer

Commented:
Is it certain that the two motherboards are the same exact model as indicated by the screen printing on the motherboard?  I've seen two Dell computers, externally identical, which used different motherboards inside.
Yes, identical part numbers.
Top Expert 2013

Commented:
did you test the ram in all the slots?
another option is flash the bios to an older version
Yes.  I've tried each of the 6 faster modules in each of the 4 slots, one at a time.

I'm VERY reluctant to flash an older BIOS as an attempt to update the BIOS is what bricked the original motherboard.  This board has no recovery method once that happens.
Top Expert 2013

Commented:
and you cannot contact Dell ? maybe they can help you out on this
My repeated experience with Dell support is that they won't provide any information for out of warranty items.  If they will, their information is often incorrect.
Top Expert 2013

Commented:
well - if you don't try it - you'll never know if you missed that 1 friendly person that had your answer
i mean - you don't loose much by trying
It appears that I was likely mistaken in my suggestion that it was a speed issue.  I think it's a capacity issue.

The only module I've gotten to work is a 2G -10600.  When the 4G and 6G -12800 modules didn't work, I concluded it was a speed issue.  I've since gotten two 8G -10600 modules and the both show the same failure.

My conclusion is that this board has a problem with 4G and larger modules.  I'm replacing the board.

Thanks to all for your suggestions!
Thanks for your input.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial