We help IT Professionals succeed at work.

Check out our new AWS podcast with Certified Expert, Phil Phillips! Listen to "How to Execute a Seamless AWS Migration" on EE or on your favorite podcast platform. Listen Now

x

Sharepoint 2016 - AD sync not updating Sharepoint User profile attributes.

Seven0fNine
Seven0fNine asked
on
High Priority
55 Views
Last Modified: 2020-06-17
Hi,

I’ve been dumped in the deep-end and inherited the companies SharePoint 2016 On-Prem system (previous expert has been signed off) .  I understand the basics but cannot fathom out what is likely a simple issue….

We have SharePoint user profiles setup to sync with AD, however the syncing process does not seem to be updating SharePoint profile information like Job Title, Dept. etc. This attributes are updated in AD and then should sync with SharePoint and update profile details like for like. However, it’s been reported that since last week any person that is searched for in the ‘People’ search - the persons profile information still displays old information and does not reflect the details in AD.

The sync connection looks ok with the correct AD OU container selected. All scheduled profile sync jobs seem to run ok and there are no obvious errors.
Any ideas on how the SharePoint user details can be updated to the correct details in AD.

Any help will be appreciated.

Thank you
Comment
Watch Question

James BunchSystems Engineer
CERTIFIED EXPERT

Commented:
Check the Azure AD Connect syncrhonize utility and look at the targets that it is hitting. Maybe this isn't running without manual attempt so you can open it, check configurations to make sure its pulling the right OU Container, then run a "DELTA SYNC".
Walter CurtisSharePoint AED
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
This is a long shot, but may be worth checking. The account used for the AD sync also needs a delegation in AD that allows for replication of AD attributes. Make sure the account shown in SharePoint as the account that the sync runs has permissions in AD.

Hope that helps...

@James Bunch - great information, however the OP stated this is on-premise.
Jeff GloverSr. Systems Administrator
CERTIFIED EXPERT

Commented:
I feel for you having experienced a similar "job Enhancement". Make sure the service account used for the Profile service has been delegated "Replicating Directory Changes" in AD.

Author

Commented:
Hi All, Thank you for your suggestions, much appreciated. I have checked the SP account used to run the sync services and indeed this account has been granted 'Replicating Directory Changes' permissions (see attached file).

There is a tool called 'ulsviewer' installed could this assist with troubleshooting?. The Sharepoint guy would use this quite often for troubleshooting.

Thanks again
Walter CurtisSharePoint AED
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
The uls viewer is a good tool, but dives very deep. If you have not used the event viewer on this issue yet that may be a good place to start.

...
Walter CurtisSharePoint AED
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
Thanks
Unlock this solution with a free trial preview.
(No credit card required)
Get Preview
Unlock the solution to this question.
Thanks for using Experts Exchange.

Please provide your email to receive a free trial preview!

*This site is protected by reCAPTCHA and the Google Privacy Policy and Terms of Service apply.

OR

Please enter a first name

Please enter a last name

8+ characters (letters, numbers, and a symbol)

By clicking, you agree to the Terms of Use and Privacy Policy.