RWW fails in Windows/10

webentpr
webentpr used Ask the Experts™
on
Hi –

I have a client running SBS 2011 and has 16 workstations attached to the domain.  They are either Windows/7 or Windows/10 clients.  They use RWW for remote access to the domain workstations.  Any Windows/7 workstation is capable of RWW – no problem to any of the workstations (Windows/7 or Windows/10.)  The problem is when the user attempts to access the domain clients from Windows/10 – they get the message
“Your computer can’t connect to the remote computer because a security package error occurred in the transport layer.  Retry the connection or contact your network administrator for assistance.”
The strange thing is the first time a Windows/10 client tries to connect through RWW it works.  After that we get this message.  Can access any workstation using Windows/7 so I don’t think it is the server nor the domain computer.
Tried deleting the history, download, etc from Internet options, but nothing changes.  Today, using a Dell laptop (Windows/10) was able to get on – but the second time I got the error message.  
Any help would really be appreciated.
Thanks
Rich
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
owner
Commented:
It turns out the fix I found worked on a laptop but not on the other workstations - here is the regedit entry
HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client
Name: RDGClientTransport
Type: Dword
Data: this worked for some computers but not for others.  The work around was to add this registry entry and then cleared the credential from the Credential Manager -

Doing this makes the connection works - but the second time the workstation tries to connect, it fails.  Clearing the Website Credential for the site, makes it work.

thanks
rich

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial