Not able to see the network adapter  after creating a Windows 2019 VM

lianne143
lianne143 used Ask the Experts™
on
Hi

I built a new Windows 2019 VM by cloning the Server template and when I went to configure the IP address, I was not able to see the network adapter .
I went to device manager and on the Ethernet controller, it has an exclamation mark.
Please see the snapshot, do I need to install any drivers, and do I need to choose a different adapter.

Please help any tutorial will be great.

Thanks
Lan-properties-snapshot.jpg
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
VMware and Virtualization Consultant
Fellow 2018
Expert of the Year 2017
Commented:
Do you have VMware Tools installed when using the VMXNET3 interface.
Rowan HawkinsSystem Integrator

Commented:
The VMXNET interfaces all need VMware Tools to be installed on the guest.
You'll want to remove the VMXNET interface from Windows Device Manager before switching the Interface type to clear the network and mac entries from the registry,
Shut down the VM and change the VM adapter to E1000e. You can technically hot add the new interface if you use a new MAC, but as you redeploy the image multiple times you can run into strange network issues in windows itself so it is better to clean it out or build it fresh with the correct adapter.

If you are doing V2P with the image, you probably don't want VMware tools on the system

You might want to review the documentation on the features of the different network adapter types.

It all depends on what you are using the image for and how cross compatible you need it to be between platforms.
Andrew Hancock (VMware vExpert / EE Fellow)VMware and Virtualization Consultant
Fellow 2018
Expert of the Year 2017

Commented:

Author

Commented:
Before the experts post i had Shut down the VM and addded the VM adapter to E1000e under the VM properties in the Vsphere console .
 and configured the static IP

But after installing the VMware tools  i can see the the vmxnet3 Ethernet adapter has appeared.

Can i leave it as it is or it will be better if i remove the VM adapter to E1000e and activate vmxnet3 Ethernet adapter .
Please suggest.

Thanks
VMXNET3-appeared-snapshot.jpg
Andrew Hancock (VMware vExpert / EE Fellow)VMware and Virtualization Consultant
Fellow 2018
Expert of the Year 2017

Commented:
Remove the E1000e network interface, and just leave a single vmxnet3 Ethernet adapter .

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial