Firefox Cannot Display Statements from Banks

MrChip2
MrChip2 used Ask the Experts™
on
I have been having an ongoing problem with Firefox when I log into my bank's website.  When I try to view a statement, I see a page full of HTML code.  Above the HTML page there is an up arrow and a blue button with the option to log into my Google Account.  The up arrow opens up another page of the same HTML code.  For a while this only happened when I used Ameriprise. Now the same problem occurs on Schwab and Wells Fargo.  The problem does not occur on Chrome, but I use Firefox 98% of the time and prefer to fix this on my primary browser.  I am running Windows 7 (if that matters).  My OS and browsers are up to date.  In Firefox I just tried changing the application settings for PDF - before they were set to "default", now they are set to open in Acrobat X Pro.  The problem still exists.  I do NOT want to be logged into my Google Account when accessing my online banking for fear of what data is being captured.

At some point I will be upgrading my Windows, but for now I am hoping a setting or proven safe plug-in will solve this.

Thanks for your help.  Let me know if you need any additional info.

P.S. As I type this I am going to change the default to open in Acrobat Reader DC, after I make sure it is up to date.  Maybe my X Pro is so old it is missing some security feature that allows it to open the PDF?

Also, not sure if this is related, but on some sites when I go to download a PDF I get a long random string of alphanumeric characters with no extension.  If I go to Downloads in Explorer, I can name the file whatever I want with a .pdf and it opens fine.  Not sure if this is related.  Would be great to solve this too.

UPDATE: I confirmed Acrobat DC was up to date.  Then I flushed my browser cache and rebooted computer.  When I tried to view a statement the same error occured.  I am attaching a screen shot to show what I see.Screenshot of HTML code that displays when I try to view a pdf statement
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Dave BaldwinFixer of Problems
Most Valuable Expert 2014

Commented:
When I use Firefox, I let it open PDFs by itself (which is what Chrome normally does).  For some reason you have Google Docs opening your page and that display is what I would expect.  Google Docs is not a PDF or web browser so it is the wrong thing to be opening either one.  I don't use Google Docs so I'm not sure what to tell you to do.  Maybe you have made Google Docs the default program for PDFs.  ??
Distinguished Expert 2018
Commented:
What happens when you try to open PDF documents other than bank statements? And have you tried this with extensions as a whole disabled? Wonder if there is a possible conflict with something else you have installed...
David FavorLinux/LXD/WordPress/Hosting Savant
Distinguished Expert 2018

Commented:
The HTML posted above shows Wells Fargo was having a problem at the time you tried to view your statement.

Logging into Wells Fargo + checking... statements look to be set as MIME == application/octet-stream so this means statements will download.

To have them show in a browser, you'd have to manually associated application/octet-stream with Acrobat.

This will break many other sites, so be sure to only enable this while you're looking at statements, then disable it afterward.
Should you be charging more for IT Services?

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

MrChip2President

Author

Commented:
David, would you please explain how I do what you are suggesting?  Also, why does it try to view the file in Google Docs?  Is there a setting somewhere I need to change?
MrChip2President

Author

Commented:
Dave Baldwin - you raise an interesting point.  I only recently started using Google Docs.  I am going to make sure I am signed out of it and try again.  Stay tuned...
MrChip2President

Author

Commented:
Thank all of you for your help.  I am thrilled that the problem is now solved!! Each of you gave me some ideas on what to check, but in the end I discovered the problem when I went to disable all my extensions per masnrock's suggestion.  As I was manually disabling my extensions I came across one that is named "Google PDF Viewer".  It is described as allowing you to view PDF files with the Google pdf viewer.  It was last updated in 2017!  I don't recall ever installing it, but I imagine it is so old it is obsolete.  When I disabled it the PDF files opened up as expected.  I am now going to uninstall it, and also review all of my extensions for others that should be uninstalled.
Distinguished Expert 2018

Commented:
Funny enough, that would be a very unnecessary addon, especially since Firefox has its own built in PDF viewer. Great that you were able to find and remove it!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial