Package reference in ASP Core 3.0

Simon Leung
Simon Leung used Ask the Experts™
on
I encounters an error when running the ASP Core app. Actually, I have no idea which Microsoft.EntityFrameworkCore should I refer in my project ? I suppose my app is running 3.0.0-preview8-28405-07. Am I correct ?

Thx
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Chinmay PatelChief Technology Ninja
Distinguished Expert 2018

Commented:
Hi Simon,

Without error description it is impossible to guess which error you are encountering, my advice is always describe the error properly so that it becomes easier for others to help. I see you are using a Preview version of .Net core, and I would advice against using it as Preview versions can spring random errors - especially when you are migrating from an older project.

Also, I noticed that you are using Visual Studio Code. Any specific reason for not using Visual Studio Community or other editions?

Regards,
Chinmay.
Dirk StraussSenior Full Stack Developer
Distinguished Expert 2017

Commented:
I'm taking a stab in the dark here, but would you not need Entity Framework Core 3.0? Refer to Announcing Entity Framework Core 3.0 Preview 7 and Entity Framework 6.3 Preview 7.
Thx. Restore package back to Microsoft.EntityFrameworkCore 3.0.0-preview.18752.1 seem fine the problem..

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial