Debug Stored Procedure from Visual Studio 2013

RadhaKrishnaKiJaya
RadhaKrishnaKiJaya used Ask the Experts™
on
Hello Experts,
I am trying to debug a Stored Procedure from Visual Studio 2013.  I have already done the followings.  When tried to Execute the code, the break points works in C# code.  But in the SP the Break Point displays the message "the breakpoint will not currently be hit...", and never goes there.  Please let me know if I am missing anything.

Under View --> Server Explorer --> Added the Database.  Picked the Stored Procedure and added the Break Points.  Also added the Break Point in the C# code in VS.

Thank you very much in advance.
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
lcohanDatabase Analyst

Commented:
I think this usually means that some of your assembly(ies) changed and not not re-built which means the Debug-Information-File (PDB) is not recent so the debugger does not know the right source-text and therefor cannot step into. Rebuilt the assemblies and make sure to attach it to the right process.

Select Debug -> Options -> Debugging -> General
Tick Enable .NET Framework source stepping.

(The steps below will also fix errors where your project is loading old assemblies/.pdb files despite rebuilding and cleaning.)
Select Tools -> Options -> Projects and Solutions -> Build and Run,
Untick Only Build startup projects and dependencies on Run,
Select Always Build from the On Run, when project are out of date dropdown.

Author

Commented:
Hello lcohan,
Thank you for your support.  I tried both the options.  It did not work.  Any other advice?

Thank you!

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial