Installing Windows 2019 Server at Dell PowerEdge R510

tjie
tjie used Ask the Experts™
on
Hi,
I want to install the Windows 2019 at the Dell PowerEdge R510 server;

The info is like the followings:

General:
The Server Dell R 510

Virtual Disk 0 Prop:
      RAID Level: 1
      Raid Status: optimal
      Size: 931.00 GB
      Operation: None

I just reset the IDRAC to its factory setting (The IP is “192.168.0.120”)
After re-booting, it starts to install Windows 2019

During the installation…..

Where do you  want to install Windows?

Name                        Total Size      Free Space      Type
Drive 0 unallocated space      1024 GB      1024 GB      offline
Drive 1 Partition 1            1024 GB      0 MB            offline
Drive 2 Partition 1            128 MB            0 MB            offline
Drive 2 Partition 2            1023.9 GB      0 MB            offline
Drive 3 unallocated space      100 MB            100 MB            offline

When I highlight any of the above Drive, there is a message: “Windows can’t be installed on this drive” (show details).
I click the “show details”; the details are as the followings: “The selected drive is offline. The drive needs to be online to install windows; click OK to get the drive online or click cancel to go back
I click “OK”
It seems there is “some progress”, but there is an “error message”.
The error message:  “We could not get the drive online (error: 0X80070001)”

Any help to let me install the Windows Server 2019 successfully to the above server?

tjie
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Hmm...That's quite an old server..isn't it?

https://www.dell.com/support/home/us/en/19/drivers/supportedos/poweredge-r510?lwp=rt

seems that thing is not on the compatibility list...Are you sure you want to go down that rabbit hole?

Use "advanced" and delete the partitions first (where you can choose the partition to install it). That should help in your case...maybe

Commented:
I’m with Thomas on this one.
Distinguished Expert 2017

Commented:
If memory serves, 2016 if not 2012 is the last supported OS for the r510.

An option you might consider is using virtualization through the age of the system might impede that as well.
I.e. VMware 6.0 is the last supported version on this platform.

If your Os is a volume license, and the need is that you need a more current system for a time, installing 2012 while extending the time to look at the newer HW that supports 2019..
CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

Top Expert 2016

Commented:
how many drives are in this system right now? Remove all that are not in the RAID1 so you can install the OS.  When you are in setup for WS you can use either f10 or shift f10 to enter the command prompt. From there start Diskpart
diskpart
list disk   //remember the 1TB disk should be disk 0
select disk 0
online
tab back into setup and refresh you should now be able to install.
Distinguished Expert 2017

Commented:
Dave,

I think the issue, depending on which perc controller is in the system whether the storage will be detected
Booting Dell openmanage or life cycle, the win 2019 is not an available OS into which the boot would stream the applicable drivers.


It might be a stretch  to use f6 to provide win2012 drivers for the controller to see if it will see the storage before you can proceed.

Author

Commented:
Hi,

Sorry for the delay; i just did the followings and got some issues:

Power Edge R510

Installing OS using the Lifecycle Controller
F10 > Select “OS Deployment” > Click “Deploy OS” > Select “Configure RAID first”
Message:
“Current RAID configuration (Step 1 of 5). The Current RAID configuration is displayed below. To delete all existing virtual disks and create a new virtual disk, click next”
Virtual disk attribute
Controller: PERC 6/I Integrated

Virtual disk: BOOT
RAID Level: RAID 1
Size: 931.00 GB

Controller: 6 Gbps  SAS  HBA
Msg: No virtual disks found on the controller
Next

2 choices:
      PERC 6/i  Integrated (by default)
      6 Gbps SAS  HBA
Just continue by default > Next
Select “Express Wizard”
ETC
Outcome: RAID Configuration successful

After RAID is successful, then all OS are populated.

From the list; the closest one is:
Windows Server 2008 with SP2 (#1)
Windows Server 2008 , x64 edition with SP2 (#2)
Windows Server 2008 R2 (#3)
Small Business Server 2008 with SP2(#4)
Essential Business Server 2008 (#5)

I tried one by one (#1 up to # 5): The same message “MEDIA NOT FOUND”

I tried with Windows 2012 R2 SP1, Windows server 2016 and Windows server 2019; all the same error message: “ Media not found”

It seems I do not have the “up to date POPULATED Operating system list; somebody could help how to get it please (please give me the link).

Thanks,
tjie
Distinguished Expert 2017

Commented:
The setup is looking for the windows OS it supports, and only media for windows 2008/2008 R2 will be recognized and processed.

The other option I think I provided which is you boot the system using the Windows server OS DISk, you then need to present it with Perc 6/.i drivers for windows 2019.  The difficult part is locating. THe asme R51x is of the generation of the R71x trying to see whether it has perc 6/i drivers for a newer os which I think 2012 is the latest. On a separate system YOu would extract the drivers and load them on a USB which you would use on the R510 os deployment..

There is no other way.

https://www.dell.com/support/home/us/en/04/product-support/product/poweredge-r710/drivers

perc 6/i were not available in newer Ry2x versions and newer.

I think even virtualization i.e. vmware might be outside last vmware supported version 5.5 which end of support last year.

Author

Commented:
Hi Arnold,

"  ...On a separate system YOu would extract the drivers and load them on a USB which you would use on the R510 os deployment."

Would you refresh or provide more details related your above wordings; i am still confused how to do it please.

Summary:
1) What drivers?
2) How to do it?

Thanks,

tjie
Distinguished Expert 2017
Commented:
Use a workstation which you presumably have.
Go to Dell.com/support  look for drivers for r710
Get the perc 6/I drivers there.
Unpack the package to a USB stick

Boot the r510 using Windows server 2012/r2 while the USB is in
At the point where it is time to select the destination storage, if not mistaken there is an option to load drivers, which you would navigate to the usn and import/load drivers got the perc 6/i
Refresh/rescan at which point you shoukd see the logical volume ....

What you need to get to is to load the drivers for perc 6/I

Please note prior comments that you are fighting an uphill battle.

Author

Commented:
Thanks, Arnold and all participated experts.
I will close this discussion (It has been too long ..)

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial