Exchange 2010 Activesync

JDBTech
JDBTech used Ask the Experts™
on
I have an issue with an Exchange server activesync sending email with attachments larger than 10MB.  I have changed all of the send/receive connector and database limits to allow 100MB attachments (because that's what our smarthost allows) and I have updated the web.config file but I am still unable to send large email via activesync/oma.  Attempts to send receive a message from the server that the message was rejected by the server.  Is there another setting besides the web.config file that I need to update to allow large attachments?  Thanks for your help!
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Jose Gabriel Ortega CastroTop Rated Freelancer on MS Technologies
Awarded 2018
Distinguished Expert 2018

Commented:
Hello the thing is that you have to configure your transport as well not just the connectors


https://messaging.faboit.com/2016/09/exchange-connectors-to-send-and-receive.html

(you don't need to change anything on web.config).
Saif ShaikhServer engineer

Commented:
Beware increasing the attachment size for the entire organization might have also it's adverse effects.

Example: If users are sending emails with large attachments, then there is a chance the all emails might stuck up in the queue and this could lead the transport service to crash.

Default limit for attachment is 10MB, so increase the size with the adverse effects in mind.
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Author

Commented:
Transport and connectors are all set to 100MB because that is what the smarthost allows.  There are no database limits for the accounts I'm using to test.  The response from Xiu Zhang in this article indicates I also have to make IIS app pool changes.  After updating the web.config to 100 MB (104857600 bytes) for both the maxAllowedContentLength and maxReceivedMessageSize I'm able to send 21 MB attachments but nothing over 25 or 30.  Does the maxRequestLength in the web.config also have to be changed?  There's a reference to that setting in this article but it isn't clear if it must be updated or not.

Author

Commented:
Does anyone have any additional comment on this?  I haven't found a solid solution to the issue.
Jose Gabriel Ortega CastroTop Rated Freelancer on MS Technologies
Awarded 2018
Distinguished Expert 2018

Commented:
1. did you check the transports and connectors ? are they configured as  shown here?

2. Set a lower 80MB for example and check if it goes out or not.

3. if 2 has success usually a 100MB email it's bigger than 100mb. so probably if the limit is strict 100mb then you should go a lil lower.

4. show some logs?

5 provide more information about the event viewer? is the server or the smarthost the one rejecting the emails?
Commented:
I think I will re-address this issue after my current exchange 2016 rollout.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial