Need to associate .wpa to Act Word Processor program

PAMurillo
PAMurillo used Ask the Experts™
on
I have a client with ACT 2013 on a Windows 10 PC. The ACT Word Processor files .wpa got associated with MS Word and do not open correctly. I need to associate .wpa with Act.UI.WordProcessor.dll in the C:\Program Files (x86)\ACT\Act for Windows folder

I have tried:
>Manually associating.WPA files to Act.UI.WordProcessor.dll but Default Apps won't display/recognize .dll programs
>Resetting the Default Apps and rebooting
>Deleting the Registry Entry for .WPA file association and rebooting
*Each of the above reverts back to MS Word.

Any suggestions?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Very unusual to associate an extension with a DLL.
Isn't there an executable that gets called when you start ACT?
Have you tried associating .wpa with the .exe that you use to start ACT!?

Author

Commented:
@ Michael
Apparently, the DLL is the Word Processor program for ACT so I assumed it was what had to be associated with the .WPA

@CompProbSolv
I'll try associating with the Act!.exe
Why Diversity in Tech Matters

Kesha Williams, certified professional and software developer, explores the imbalance of diversity in the world of technology -- especially when it comes to hiring women. She showcases ways she's making a difference through the Colors of STEM program.

Author

Commented:
@CompProSolv
I tried the association with Act.exe (the one for the ACT version) but no luck. The computer re-associated the .WPA with MS Word.

I will try using one of the other computers on the network that has ACT, export the file association registry key, deleting the registry key on the computer with the issue, then importing the one from the other computer or I will try uninstalling/reinstalling ACT on the computer with the issue.
Do you know what version of ACT your client is using? Apparently, older versions have issues with Windows 10. Here's an article showing some of the problems and workarounds:

Act! Knowledgebase Help Center

Paul
I'm running Act! 2010 and the .WPA files are associated with ActSage.exe.  I created a .wpa file from Act!.  When I double-click on the file (whether or not Act! is open, the file opens in the Act! word processor.

If you right-click on the file and left-click on Open With....  do you see Act!?  What happens if you select it there?

Commented:
There is a "word processor" setting from within ACT!   You can open ACT! and click Tools, Preferences.  Look for a "Communication" tab and change the word processor from "MS Word" to "ACT! word processor".

Then you should be able to open these files from within ACT! under Write, Other Document - etc.

Hope that helps


Steve

Author

Commented:
Guys,
Sorry but none of the solutions worked.
I even tried copying the Registry entry for the .WPA from a 'good' machine to the machine with the issue.

I think ultimately, my solution is to uninstall/reinstall ACT.

I am waiting for my client to either decide if they want to upgrade ACT or if they want to stick with the same version. I'll let you know asap.
If you right-click on the file and left-click on Open With....  do you see Act!?  What happens if you select it there?

Author

Commented:
@CompProbSolv
I am meeting my client tomorrow and will try that and/or uninstall/reinstall or upgrade ACT.  I'll update ASAP.
So installing the latest version of ACT Pro v21 did not fix the issue.

To clarify: I am trying to open a .WPA file (That's an ACT Word processor document) that is saved in the History tab of a contact. When I try to open the file, MS Word starts it gives me the 'gibberish' window.
**This happens on all .WPA files whether I try to open them in the History tab or directly in their saved folder. It's a Windows 10 PC with ACT v 21

Here's what I've tried:
**ACT Preferences are set to use ACT Word Processor as the default word processing program
>Opening a .WPA file by first opening the ACT Word Processor, navigating to the folder, then closing the document then trying to re-open under the History tab
>Manually associating.WPA files to Act.UI.WordProcessor.dll (Right-click on the file, 'Open with...' link to the Act.UI.WordProcessor.dll
  >When done, ACT the (database program)tries to open then errors and shuts-down
>Resetting the Default Apps in Windows Settings and rebooting
>Deleting the Registry Entry for .WPA file association, rebooting, then trying to open a .WPA
*Each of the above reverts the default back to MS Word

Any suggestions would be appreciated

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial