DEll PowerEdge R510 needs to install OS Windows 2019 Server

tjie
tjie used Ask the Experts™
on
Hi,
I need to install Dell R510 with the OS Win Server 2019.
Per suggestion one of the Expert of EE, I have to download the BIOS of a Dell machine R710.

I am not sure here; I have a Dell server R720; is it workable?
I have already EXTRACT the Bios of R720 into a USB Stick.

I have here with me the OS of Windows 2012, 2016 and 2019.

I am still confused here:
I will try to install the OS at R510 by deploying the OS;
I will put The Windows 2012 OS; then, where can I INSERT the above USB stick which has the BIOS of R720 in it? What key should I press or select?

Is there any other driver should I download from Machine R720?

Thanks,
tjie
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
I'd start with just trying to install Server 2019 with the machine as it is.  If you install from a USB (download the ISO from Microsoft and use Rufus to create the USB stick), it's fairly quick.  If that installs, go ahead and download the latest R510 BIOS.  I'd be cautious about using the BIOS from any other model unless you have someone very credible claiming otherwise.

There is a BIOS available from last year on Dell's site: https://downloads.dell.com/FOLDER05020740M/2/BIOS_PYCXX_WN64_1.14.0_01.EXE

Dell doesn't have drivers for that model for any server version newer than 2012 R2.  That leaves you with a couple of options.  You can try to install 2019 and see how you do with drivers.  If the actual server will be one or more VMs (highly recommended), then it may not be a problem if you don't have all the drivers for 2019.  I'd give it a try and see what can't be resolved in Device Manager.

The second option is to install Server 2012R2 as the host, then use 2019 as the VMs.  I've had success with that before on older servers.

Author

Commented:
Hi comProbSolv:

What driver is it? from what machine?
 https://downloads.dell.com/FOLDER05020740M/2/BIOS_PYCXX_WN64_1.14.0_01.EXE

I have the machine R720; i am not sure it can be used for R510?
or somebody has a machine R710? If yes, please post the link so i can get the Bios for R710 .

Note: I did install the Server 2019 direct but failed; no BIOS populated related to the 2019

Thanks,
tjie
"I have the machine R720; i am not sure it can be used for R510?":  This isn't clear to me.  Is the actual, physical server that you have a R720, R510, or ?

"no BIOS populated related to the 2019": I don't know what that means.  When you tried to install Server 2019, did it find the drives?  Did it start to install?  Did you install from booting a USB stick?

More details about what you have done and what the results were would be very helpful.
Fundamentals of JavaScript

Learn the fundamentals of the popular programming language JavaScript so that you can explore the realm of web development.

Top Expert 2014

Commented:
In your previous question Arnold suggested searching Dell's website under a different machine to get PERC drivers for a later version OS, not to put the BIOS of that machine on this one. That method sometimes works because of the way they generate the list of files available for a particular model.

Say (for example) two generations of servers both use the same device but the earlier generation isn't supported on a later version OS then you may still find the right driver listed on the web if you pretend you have the later version server. It's not a technical thing, just a trick to get around Dell not listing the later drivers for the earlier machine on the website. (and I'm pretty sure it won't work in your case).
Andy makes an excellent point.  I hadn't see the earlier question.  Nothing wrong with grabbing the PERC driver and firmware for your OS from a different model server.  The controllers should be the same.

Thats FAR different from using a different system's BIOS.  In general, the installer won't allow it, but I'd avoid trying.
Top Expert 2014

Commented:
"is it workable?"

No. Backwards compatibility is easy you run the old code on the new hardware, forwards compatibility is harder since you cannot predict the protocols of the future. A new server can run ancient code by disabling some functions but an old server can't run algorithms that weren't invented when it was made,

Author

Commented:
Hi,

I have IDRAC version 3.3 dated 9 january2017 in USB stick.
Question: How I update this server with this IDRAC version 3.3 above?  A little bit of step is helpful.

Thanks,
tjie
I wouldn't spend any time on iDRAC until you've resolved the issue of installing Windows Server.

Author

Commented:
Note:
I have never worked with Dell Server; After several failed testing (back and ford with Dell Tech Sup), finally, Dell tech support replaced the IDRAC card (now IDRAC is functioning). The Goal is to install OS in this server, either Win 2016 or Win 2019. To be able to achieve this, I believe I must know how “to update the software or firmware” properly. Now, I have problem in the 2 areas which are “the right method to update the firmware”, and “installing OS”

To make CLEAR what my server has got now, here are the installed components:

Component Name                                    Version
PERC 6/I Integrated (Slot 4-1)                              6.3.0-0001
6 Gbps SAS HBA (Slot 3-1)                              07.02.42.00
IDRAC6                                                2.85
BIOS                                                1.14.0
Dell Lifecycle controller,       V.1.4.0.586, A03                  1.4.0.586
Dell OS Drivers Pack,15.04.00, A00                        15.04.00
Dell 32 Bit Diagnostics,  Version 5162 installer                  5162A0
Revision 14.05.00, 5162A0, 5162.1
Broadcom Nextreme II Gigabit ….(Embedded 1-1)            08.07.26
Broadcom …. (Embedded 2-1)                              08.07.26
Broadcom … (Slot 1-1)                                    08.07.26
Broadcom … (Slot 1-2)                                    08.07.26
Power Supply                                          03.02.00
Power Supply                                          03.02.00



The FIRST issue: “The right method to update the firmware”
The things that I have done:
I follow the you tube which title” Dell lifecycle controller – firmware update using local drive (CD or DVD or USB)
Per You tube: F10> Select Firmware update> check virtual Media> Click connect virtual media > then, initialization start > click virtual media again > select map removable disk>click Map device> then, launch firmware update> select local drive (as repository location)>next > on the “enter access details” screen: the local drive that we selected is shown> then, the EXE file name in the field “package field” >then, click Next
The things that I have in my server:
I did not see “Firmware update”; the things that I have is “Platform update”
I click “Platform update” > then, it brings me to “update the platform”> I click it> then, in the local repository… I saw  USB0.
Here, I do not see “any VIRTUAL MEDIA” (which I have to click “connect to virtual media”).
The error message that I got: “Catalog file not found. Make sure that the windows ® catalog and Dell (TM) update packages for Windows (R) are used.”; ANY PROPOSED SOLUTION FOR THIS (proposed solution#1)?

The SECOND issue: “Installing the OS (either Win 2016 or 2019; preferably Win 2019)”
The things that I have done:
Installing OS using the Lifecycle Controller
F10 > Select “OS Deployment” > Click “Deploy OS” > Select “Configure RAID first”
Message:
“Current RAID configuration (Step 1 of 5). The Current RAID configuration is displayed below. To delete all existing virtual disks and create a new virtual disk, click next”
Virtual disk attribute
Controller: PERC 6/I Integrated

Virtual disk: BOOT
RAID Level: RAID 1
Size: 931.00 GB

Controller: 6 Gbps  SAS  HBA
Msg: No virtual disks found on the controller
Next

2 choices:
      PERC 6/i  Integrated (by default)
      6 Gbps SAS  HBA
Just continue by default > Next
Select “Express Wizard”
ETC
Outcome: RAID Configuration successful

After RAID is successful, then all OS are populated.

From the list; the closest one is:
Windows Server 2008 with SP2 (#1)
Windows Server 2008 , x64 edition with SP2 (#2)
Windows Server 2008 R2 (#3)
Small Business Server 2008 with SP2(#4)
Essential Business Server 2008 (#5)

I tried one by one (#1 up to # 5): The same message “DRIVERS PACK NOT FOUND”

I tried with Windows 2012 R2 SP1, Windows server 2016 and Windows server 2019; all the same error message: “ DRIVERS PACK NOT FOUND”

It seems I do not have the “up to date POPULATED Operating system list” (So It DID NOT work with this APPROACH)

Ok,
I try different method of INSTALLATION of OS.
EXIT and REBOOT

Boot Settings:
+Boot Mode
+Boot Sequence
+Hard-Disk Drive Sequence
+USB Flash Drive Emulation Type
+Boot Sequence Retry

I select “Hard-Disk Drive Sequence”
+Slot 4 PERC 6/I Integrated (Bus 02 dev 00)
+Front USB: Data Traveller 3.0

I select “Front USB: Data Traveller 3.0”
Save changes & Exit.
The system prompted with the CD key.
I gave the CD key.

Then, it prompted the followings:

Where do you  want to install Windows?

Name                                    Total Size      Free Space      Type
Drive 0 unallocated space      1024 GB      1024 GB            offline
Drive 1 Partition 1                  1024 GB      0 MB                  offline
Drive 2 Partition 1                  128 MB            0 MB                  offline
Drive 2 Partition 2                  1023.9 GB      0 MB                  offline
Drive 3 unallocated space      100 MB           100 MB            offline

When I highlight ANY of the above Drive, there is a message: “Windows can’t be installed on this drive” (show details).
I click the “show details”; the details are as the followings: “The selected drive is offline. The drive needs to be online to install windows; click OK to get the drive online or click cancel to go back
I click “OK”
It seems there is “some progress”, but there is an “error message”.
The error message:  “We could not get the drive online (error: 0X80070001)”
I click “OK”
Then, it is good; it is online now.
But there is another error message “To ensure that all windows features work correctly, windows might create additional partitions for system files”
I click “OK”.
I saw it is “running” for a few minutes, then there is another message: “Windows could not create a partition on disk 0. The error occurred while preparing the partition selected for installation. Error code: 0 x 80042453
I click “OK”
Then, it backs to “install windows”; need the CD key again…. So everything is does not work.
ANY PROPOSED SOLUTION FOR THIS (proposed solution #2)?

Thanks,
tjie
Top Expert 2014

Commented:
Can't you use firmware update using network? then you can use ftp.dell.com as the repository location and let it pull down the files it needs automatically.
Your second approach (avoid Dell's system and just install the OS directly) is the method I typically use, especially when using a newer (non-supported) OS.

When you got to the screen that listed the different partitions, it indicates that the drives 1 and 2 are both 1T drives (or arrays) that have already been partitioned.  The first issue to sort out is why are there two 1T drives listed?  I'm not seeing any notes from you on how many physical drives you have.  If there are 2 1T drives configured as RAID1, then only one should be showing up here.

I'd reboot, go back into the RAID configuration (Ctrl-R?), and confirm how many drives it is seeing and how they are configured.  Assuming there is no good data on the drives, I'd delete the array and recreate it.

The second issue is that the drives are listed as "offline".  I've not run into that before but found a number of suggestions by doing a Google search on "windows server installation drives offline".  One suggestion was to use Diskpart to clean the array, recreate the array, then convert it to GPT (if that's what you want).  I'd not do anything with this until after the previous issue (2 drives being shown) is resolved.  https://community.spiceworks.com/topic/2049895-windows-server-2016-installer-showing-disk-offline

This provides a more complicated solution: https://support.microsoft.com/en-us/help/2345135/setup-reports-error-windows-cannot-be-installed-to-this-disk-when-boot

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial