We help IT Professionals succeed at work.

After Win10 update to 1903 the mouse doesn't work right.

Medium Priority
111 Views
Last Modified: 2019-11-17
Win 10 Pro on Dell Optiplex XE with 32GB Ram, SSD hard drive.  Customer updated to 1903, newest upgrade. After that the mouse is screwy. It can happen in many different ways but it’s not reproducible every time. Here’s how he describes some of the symptoms:


On Google Calendar he will be on the October page, click to go to November and instead it skips over to the December page.

He has Picasa up on his screen. His Gmail is open in a browser window beneath it. Clicking on a picture in Picasa opens an email.

He goes to write an email. Clicking on compose opens two compose windows instead of one.
 
In powerpoint, he clicks the X to exit and instead it goes to print.

Thanks,
Al
Comment
Watch Question

CERTIFIED EXPERT

Commented:
Some (not all) of the symptoms sound as if the computer is registering a single click as a double click.  I'd change the settings for that in Control Panel, Mouse.  Also, have you tried a different (wired) mouse?
Systems Administrator
CERTIFIED EXPERT
Commented:
This is a known issue:
See https://www.youtube.com/watch?v=zseijWTbVFs
Some of the subsequent updates attempt to address the mouse issues.

To get to the mouse settings dialogue after logging in, <win>R for the Run dialogue
control main.cpl

Tab allows you to move around the controls.  When the marquee is around "button" or the title of the tab, pressing the left or right arrow allows you to navigate to the other tabs. Mouse drivers can change what tabs are available.

Author

Commented:
Still working on this. Tried most of the things from various websites. I wonder if using a logitech mouse or a wireless mouse would get around it.
Al
CERTIFIED EXPERT
Distinguished Expert 2019

Commented:
you can Always uninstall it -  and wait for the fix

Author

Commented:
Thanks to all,
Al

Author

Commented:
FYI. I had the customer take the mouse out of the USB 3.0 port and plug it into a USB 2.0 port. That resolved the problem. I looked at lots of solutions online but never saw this one.
Best,
Al

Explore More ContentExplore courses, solutions, and other research materials related to this topic.