We help IT Professionals succeed at work.

service won't start on 2016 Data center

Medium Priority
128 Views
Last Modified: 2019-10-28
I have a service written in Delphi.  it has been tested and run on many machines.
it writes to a log file(on create/install/uninstall), then starts an executable periodically

however, setting it up on a new 2016 server VM (created through Azure if that helps)
isn't going to well.

the log file isn't being written to(ever), and the the service absolutely is refusing to start.

the application it is starting has been tested and is runs with no issue.

the Account being used is the local system.
we have also tried using the admin user, same result.
It fails with error 1053,  and no log is generated (I have startup message in the create statement), I don't know where to look

any idea would be appreciated
Comment
Watch Question

Philip ElderTechnical Architect - HA/Compute/Storage
CERTIFIED EXPERT

Commented:
First, set up a dedicated local account. Admin should not be needed.

System is not a good idea at all.

Once the account is set up, then set that account for the Log On setting for the service.

The last step is to give that account FULL permissions to the root folder(s) it needs to access and propagate that to all subfolders.

We've set this up for funky apps in the past and it works well.

If there's something still amok, use Process Monitor to figure out where it is get hung up.
RobertSystem Admin
CERTIFIED EXPERT

Commented:
I agree that what Philip suggested as a good starting point but want to add try turning off UAC, test with it off, then turn back on. at least that will tell you if it is UAC blocking something.
I have also had 1 or 2 occasions where DEP blocked things.
Just a simple programmer
Commented:
turns out, it was simply because the display name of the service was the same as the name of the service.
I have code that changes the display name, based on the name of the executable(because some of our customer sites need the same service to be running, just from different locations), so I made it do that.  Not being familiar with services, I wasn't aware that service display name had to be different from exe name.

Explore More ContentExplore courses, solutions, and other research materials related to this topic.