Clean up Security settings on a hard drive.

Fred Marshall
Fred Marshall used Ask the Experts™
on
I have a computer with 2 hard drives, the OS hard drive C: and a file container hard drive D:

It seems that no matter what procedure I try on the D: drive to set Security, I end up when it propagates permissions I get:
Failed to enumerate objects in the container. Access is denied.

The approach that seems to be recommended most often is changing the ownership to the current user and propagating the result.

I still get:

An error occurred while applying security information :
[foldername]
Failed to enumerate objects in the container.  Access is denied.
[CONTINUE] and on to the next folder with the same message.

It appears that I've been able to get file access down ONE level in the folders and no more.

There's a lot of data (and folders) on this drive and I'd like to propagate an effective cleanup of Security permissions.

Is there a way?
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2013

Commented:
i would look in event viewer for any related problems
also - checking the health of the drive can help

Commented:
I would try change the ownership to the local administrators group and propagate.
What account has ownership now?
Is your in the administrators group?

Author

Commented:
65td:  I've tried a number of new owners.  The problem is that the settings won't propagate.
Acronis in Gartner 2019 MQ for datacenter backup

It is an honor to be featured in Gartner 2019 Magic Quadrant for Datacenter Backup and Recovery Solutions. Gartner’s MQ sets a high standard and earning a place on their grid is a great affirmation that Acronis is delivering on our mission to protect all data, apps, and systems.

Author

Commented:
I'm seeing a lot of warnings in Event Viewer:

The machine-default permission settings do not grant Local Activation permission for the COM Server application with CLSID
{C2F03A33-21F5-47FA-B4BB-156362A2F239}

I looked it up and it gives rather pointed instructions:

1. Open Regedit
2. Go to HKEY_Classes_Root\CLSID\{C2F03A33-21F5-47FA-B4BB-156362A2F239}
3. Right click on it then select permissions  
4. Click Advance and change the owner to Administrators group. Also click the box that will appear below the owner line. ("Replace owner ...")
5. Apply full control

6. Go to HKEY_LocalMachine\Software\Classes\AppID\{316CDED5-E4AE-4B15-9113-7055D84DCC97}
7. Right click on it then select permission
8. Click Advance and change the owner to Administrators group
9. Click the box that will appear below the owner line
10. Click Apply and grant full control to the Administrators group

11. Go to Administrative tools
12. Open component services
13. Click Computer, click my computer, then click DCOM
14. Look for the corresponding service that appears on the error viewer [Immersive Shell]
15. Right click on it then click properties
16. Click security tab (and then what?? There are 3 sections.) then click Add User. Add Local Service then apply
17. Tick the Activate local box

The drive in question is in a "new" system, installed with no changes made to it.  Well, same system, new OS drive.  I suspect this may have something to do with it but I've had issues with it like this before it seems.
Top Expert 2013

Commented:
whta do you mean with 'Well, same system, new OS drive.'

Author

Commented:
nobus:  I don't want to divert the discussion but here is the ugly answer:
This is a new computer and I had set aside the original OS drive.  Put it back in.
Thus, "same system, new OS drive"
Here, I'm dealing with a 2nd data drive.  I could reformat it  but restoring its data would be quite a chore - so I'd like to fix the Security if I can.
Top Expert 2013

Commented:
forgive my ignorance, but :
- This is a new computer and I had set aside the original OS drive.  Put it back in.
Thus, "same system, new OS drive"
i don't understand how it is a new OS drive - if you put the Original in??

Author

Commented:
New Computer WITH New OS HD.
Remove New OS HD
..
later
..
Restore New OS HD to New Computer to which the New OS HD was the "original".
Top Expert 2013

Commented:
just to be sure - run sfc / scannow
...and do a chkdsk to be sure there are no problems with it
I didn't find a solution to the permissions issues problem and ended up formatting the drive.
Well, that *is* a solution but not the one I wanted.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial