Cannot install HP LaserJet Pro M1210

tonyadam used Ask the Experts™
I can download the drivers from HP but when attempting to install after the extract, nothing happens.  This is a W10 Home 64 bit system.  Thoughts on how to force an install?
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Paul MacDonaldDirector, Information Systems

"...when attempting to install after the extract, nothing happens..."
Reboot your computer.  Once you've logged back in - before starting anything else - run the installer.  

It's exceedingly unlikely that "nothing happens", but if you literally start the installer and it stops with no messages, post back with that.  If there are any other indications, dialogs, messages, windows, prompts, etc, post back with those.

Did you download the driver straight from HP, or through some third party?
RobertSystem Admin

Try the following.
1. uninstall the driver
2. unplug the printer
3. reboot
4. install the driver
5. when prompted plug in the printer

There are some goofy things about the HP printers that connect via USB.
It is annoying but you usually have to follow their steps or it wont work.


There are no HP printers installed.  I believe that there are no HP drivers installed.  We do have the full pak sitting in downloads but everytime we tried to install it, it extracts the pak and then does errors...nothing.  

We followed your suggestions sans the uninstall driver since I don't believe one is installed.  Unplugged the printer from power and the USB connection to the computer.  Rebooted the computer (W10 Home) and tried to reinstall the HP printer package.  The same behavior occurred.   Ideas?
I do a lot of computer volunteer work and one of things I've learned is that  HP printer installs can be quirky.  This is another example.  The printer is now installed.  All HP had to tell us to do was to power up the system, install the USB cable and the printer install function simply starts.  I wasted over 4 hours trying to solve this problem and I do appreciate your help as well.  Unfortunately, none of things you suggested or my previous knowledge solved the problem.   We found some old documentation which suggested doing this install process and it worked.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial