error pushing app

chalie001
chalie001 used Ask the Experts™
on
error pushing app to heroku
git push heroku master
Enumerating objects: 954, done.
Counting objects: 100% (954/954), done.
Delta compression using up to 4 threads
Compressing objects: 100% (939/939), done.
Writing objects: 100% (954/954), 8.52 MiB | 543.00 KiB/s, done.
Total 954 (delta 122), reused 0 (delta 0)
remote: Compressing source files... done.
remote: Building source:
remote:
remote: -----> Python app detected
remote:  !     Requested runtime (python-3.5.1) is not available for this stack (heroku-18).
remote:  !     Aborting.  More info: https://devcenter.heroku.com/articles/python-support
remote:  !     Push rejected, failed to compile Python app.
remote:
remote:  !     Push failed
remote: Verifying deploy...
remote:
remote: !       Push rejected to appname.
remote:
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Top Expert 2016
Commented:
python 3.5.1 is not supported
only python-3.8.0 on all supported runtime stacks
python-3.7.5 on all supported runtime stacks
python-3.6.9 on all supported runtime stacks
python-2.7.17 on all supported runtime stacks
are supported

Author

Commented:
I did put python-3.8.0 in my runtime.txt but still getting error

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial