Avatar of chalie001
chalie001
 asked on

vbox client not strating

vboxclient not starting in my ubuntu
vboxclient32
Linux* Virtual BoxVirtualizationLinux NetworkingUbuntu

Avatar of undefined
Last Comment
noci

8/22/2022 - Mon
DIPRAJ

hi,
 as per understanding some required package is missing.
please run the following command for required package to be installed.

sudo apt install linux-headers-$(uname -r) build-essential dkms


after package has been installed, please reboot the system and then load additional package / installation tools from guest image/ cd/media.

Thanks.
Peter Chan

Hi,
I can see your Vbox has been started already.
noci

You need the guest tooling installed in the guest for seamless integration. (The Guest can work without it, it helps when using the mouse & keyboard a lot and your want the guest to behave like a regular client. (otherwise remember to use the right control key to release keyboard & mouse  from the guest window)
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes
chalie001

ASKER
am still not able to increase resolution
ASKER CERTIFIED SOLUTION
noci

THIS SOLUTION ONLY AVAILABLE TO MEMBERS.
View this solution by signing up for a free trial.
Members can start a 7-Day free trial and enjoy unlimited access to the platform.
See Pricing Options
Start Free Trial
GET A PERSONALIZED SOLUTION
Ask your own question & get feedback from real experts
Find out why thousands trust the EE community with their toughest problems.
chalie001

ASKER
am geting this
resol
noci

it is   xrandr -s 1600x1200   (using x) not xrandr -s 1600*1200 (using asterisk).
Strange... one time you copy stuff verbatim... other times you interpret freely... difficult to anticipate....

With x it tries to match the string with one of the  allowed modes. if matching fails it interprets the numeric value of the string is 1600 (leading numeric part)...
Just running xrandr will give allowed settings.
index 0 is the first entry of the list of values, 1 the 2nd....
so xrandr -s 0 would select the first element of the list.
⚡ FREE TRIAL OFFER
Try out a week of full access for free.
Find out why thousands trust the EE community with their toughest problems.
chalie001

ASKER
so i must type this  xrandr -s 1600x1200 everytime i start the vm
noci

Or put it in the login script ~/.profile