Avatar of Joy Gomez
Joy Gomez
 asked on

Unknown namespace error when creating ribbon

Hello while trying to create a ribbon, I am getting the following error.  Attached is the error message and below is the xml  i have in the UsysRibbons table.

<customUI xmlns="http://schemas.microsoft.com/office/2006/01/customUI">
  <ribbon startFromScratch="false">
    <tabs>
      <tab idMso="TabCreate" visible="false" />
      <tab id="dbCustomTab" label="A Custom Tab" visible="true">
        <group id="dbCustomGroup" label="A Custom Group">
          <control idMso="Paste" label="Built-in Paste" enabled="true"/>
        </group>
      </tab>
    </tabs>
  </ribbon>
</customUI>
Picture1.png
Microsoft Access

Avatar of undefined
Last Comment
Joy Gomez

8/22/2022 - Mon
Anders Ebro (Microsoft MVP)

Your schema name is incorrect due to the capitalization of UI at the end. Use this:
<customUI xmlns="http://schemas.microsoft.com/office/2006/01/customui">

Open in new window


Working with access we are so used to things not being case sensitive that it can be a bit confusing that the ribbon is case sensitive in certain areas.
Joy Gomez

ASKER
Hi... I changed that also and keep getting the same error.
SOLUTION
John Tsioumpris

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
Anders Ebro (Microsoft MVP)

Try to write it EXACTLY as I did in my post. The first is customUI while the second is customui

Doesn't make sense, but that is how it is.
Your help has saved me hundreds of hours of internet surfing.
fblack61
Joy Gomez

ASKER
Anders... I copied it exactly.  I also copied and pasted what John send.... still gives me that error.  

So I tried to take out everything except, putting this tag... and I get a second message for Line:12, Column: 11 - that does not even exist.  Attached is the message.
<customUI xmlns="http://schemas.microsoft.com/office/2006/01/customui" ></customui>
pic1.jpg
Joy Gomez

ASKER
If i put this url in chrome (http://schemas.microsoft.com/office/2006/01/customui)

then I am getting a message: The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.
ASKER CERTIFIED SOLUTION
Log in to continue reading
Log In
Sign up - Free for 7 days
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
Joy Gomez

ASKER
Nope.... just one
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
Joy Gomez

ASKER
Thanks Anders and John for your responses.