Avatar of MikeDTE
MikeDTE
Flag for United Kingdom of Great Britain and Northern Ireland asked on

Fixing BOOTMGR is Missing

I am trying to help a client with his very old PC.

The PC is a 10 year old HP Desktop originally installed with Windows 7.  It was upgraded to W10 before I saw it.

The original hard disk is fitted and still spinning.  I need to replace it.  He has 214GB of data (which I have made safe).  It has 70 installed apps not including all the standard MS Visual C and Driver Packages.

Original plan was to use a hardware cloning device but the disk has unrecoverable disk errors in free space and will not clone.

This disk is not GPT it is definitely MBR

Used  AOMEI Partition Assistant Pro  to complete (successfully) a software clone of the C: drive ‘System’ partition (no errors).  On fitting the disk back into the PC I get “BOOTMGR is missing” Press Ctrl+Alt+Del to restart.  

This in the only disk fitted and it has a single partition so BIOS is all set-up as it should be. Used AOMEI to rebuild MBR and Set Partition Active.  Also worked through all the W10 recovery options to fix the issue. Worked through DiskPart to select disk and partition and then I need to set the partition ID using ‘set id’ using:

set id=c12a7328-f81f-11d2-ba4b-00a0c93ec93b

This causes an error saying “The specified type is not in the correct format”
I have followed examples of how and what I should type in using advice from here:
https://www.easeus.com/partition-manager-software/fix-bootmgr-is-missing.html
The screen shots show what I have typed is in the correct format - or does it mean the the disk is not in the right format?  Either way if anyone can provide advice it would be a help.
SoftwareWindows OSWindows 7PC

Avatar of undefined
Last Comment
nobus

8/22/2022 - Mon
Robert Retzer

The problem probably is due to when the user did an in place upgrade from windows 7 to windows 10. This is sometimes known as a dirty install and the installation files of both operating systems are still on the hard drive. both windows 7 and windows 10.  Even if the system was imaged from the old system it is possible that boot manager stuff is what is causing the issues when trying to image. It sounds like you have spent a lot of hours trying to fix this issue. I would probably just go ahead and reinstall the window 10 OS and transfer the user's data.  Then manually install the applications he needs.
ASKER CERTIFIED SOLUTION
nobus

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck