Permissions insufficient to perform this operation when attempting to deploy SSRS Shared Data Source

Dale Fye
Dale Fye used Ask the Experts™
on
I'm attempting to create a couple of SSRS reports and publish them to a clients Report Server.

First I got an error:  
cannot deploy the report because the shared data source ... does not exist on the report server.

I found a reply to that which indicated that I need to deploy the shared data source before deploying the report.
I would argue that this makes no sense because that data source already appears to exist on our report server because other reports that work on that Server/database are working properly.  At any rate, I right clicked on the shared data source in question, selected deploy, and now I'm getting an error:

The permissions granted to 'client\userid' are insufficient for performing this operation.
1.  What permissions do I need to deploy this datasource?
2.  Are these windows permissions or something else?

This is all caused by my client eliminating my Citrix login and giving me a remote desktop login, I've lost some of my permissions and don't know what to tell them in order to get these permissions right.

Thanks,

Dale
Comment
Watch Question

Do more with

Expert Office
EXPERT OFFICE® is a registered trademark of EXPERTS EXCHANGE®
Database Analyst
Commented:
SSRS security ties lot more to AD logins than SQL logins so depending on the new login you are using vs the old Citrix...things may be lot different and whomever made the switch should grant identical permissions in SQL - SSRS included to the RDP login as they were for that Citrix login.

Until that's done...your RDP login is hopefully a domain login and not a local user and in that case you can follow steps below to grant your domain\username the "Content Manager" SSRS role needed for your type of work:

Run internet explorer as Administrator            
Open the report Manager URL, Go to "Site Settings" in the top right corner
Click Security then "New Role Assignment"
Enter your domain\username and select System Administrator, click ok
Click home, Folder Settings, then New Role Assignment
Enter your domain\username and select Content Manager, click ok

At least I think you need to be given the highest SSRS role however if you just need to be able to publish report then Publisher role may be enough and see below full list of predefined SSRS roles

https://docs.microsoft.com/en-us/sql/reporting-services/security/role-definitions-predefined-roles?view=sql-server-ver15#bkmk_content
Dale FyeOwner, Dev-Soln LLC
Most Valuable Expert 2014
Top Expert 2010

Author

Commented:
How do I get the Report Manager URL?  Is that in Visual Studio settings somewhere?
lcohanDatabase Analyst

Commented:
The "report Manager" URL is in the SSRS configuration file and if you don't have access to that someone that has RDP access to that SQL Server and can run the SSRS Configuration tool can get it for you.
By default, the URL is https://<serverName>/reports and more details are here: https://docs.microsoft.com/en-us/sql/reporting-services/tools/tutorial-how-to-locate-and-start-reporting-services-tools-ssrs?view=sql-server-ver15
Dale FyeOwner, Dev-Soln LLC
Most Valuable Expert 2014
Top Expert 2010

Author

Commented:
Thanks for your help.

Between the link you provided in the 2nd post, and the instructions provided in the first post, I was able to resolve my issues.

Do more with

Expert Office
Submit tech questions to Ask the Experts™ at any time to receive solutions, advice, and new ideas from leading industry professionals.

Start 7-Day Free Trial