Link to home
Create AccountLog in
Avatar of IP4IT Staff
IP4IT StaffFlag for Ireland

asked on

How to setup HTTPS connection for website via licensing with AutoSSL

Hi,

We created a new website and replaced old website with this one.

The URL is the same as we were using and with same hosting provider.

We manage our website through cPanel in WHM.

When searching our website, it comes up as "Not Secure".

Our website used to be listed as secure.

Our provider mentioned that we used AutoSSL for licensing.

I am not to knowledgeable on how to use AutoSSL to get certification as it was setup a few years ago.

We would like to set our site to load in HTTPS using AutoSSL.

How would this be done?

Thanks,
Robbie
Avatar of Scott Fell
Scott Fell
Flag of United States of America image

Did you replace files in your current site or did you create a new site in cpanel or  new hosting service, then uploaded the new site and pointed the domain to the new IP? If that is the case, you just need to start the process over again.  https://blog.cpanel.com/autossl/
Avatar of IP4IT Staff

ASKER

Hi,

I created new site and replaced old website files in cPanel with new website files.

Our hosting service is still the same.

Does the AutoSSL need to be reconfigured?

Thanks,
Robbie
That is odd. Just replacing files on the same server shouldn't break your certificate.

I think AutoSSL is just an automation for LetsEncrypt. Just rerun it.
Hi Scott,

In our WHM, I see under "Under SSL/ TLS", there is only one option; "SSL Storage Manager".

In WHM, for our domain, displayed under "User Account SSL Resources", we have one subdomain with a self-signed license but still appears as "not secure", our domain and other subdomains are not listed.

In cPanel for our domain under "General Information", a message says "Primary Domain (No Valid Certificate)".

In cPanel, under "SSL/ TLS" - "Manage SSL Hosts", there is a message that says under "Install an SSL Website";
"Note: You don’t have a dedicated IP address. Browsers that were released before 2013 may not support SNI. Because of this, users may see false security warnings when they visit your SSL-secured websites."

What would you recommend we do get rid of "Not secure" message for our domain?

Thanks,
Robbie
"we have one subdomain with a self-signed license but still appears as "not secure", our domain and other subdomains are not listed"

A self-signed certificate will probably come up as not secure. You will either need to purchase a certificate or use a free lets-encrypt. With the paid certs, I think they can be purchased for up to 2 years. With lets-encrypt, you have to reinstall every 6 months.

My original advice was to re-run your autossl which should install a lets-encrypt certificate. Just stay away from a self-signed cert.

https://blog.cpanel.com/autossl/
https://blog.cpanel.com/announcing-cpanel-whms-official-lets-encrypt-with-autossl-plugin/
Hi,

In our WHM, SSL Storage Manager only displayed under SSL/TLS. No sign of "Manage AutoSSL" OR "Run AutoSSL".

No command lines or terminals displayed or accessible in cPanel or WHM.
 
Our WHM version seems to be CLOUDLINUX 7.7 xen hvm v84.0.18.

1. Is there a way of displaying these options or are they not accessible to us?
2. How would we go about re running AutoSSL and installing Lets-Encrypt?

Thanks,
Robbie
Hi,

I have checked online and for our hosting provider, they have mentioned that; "At this time, we do not support free SSL certs (such as AutoSSL or Let’s Encrypt) on our shared hosting servers".

Could this be the reason I can't find option to re-run autossl?

What do you think?

Thanks,
Robbie
ASKER CERTIFIED SOLUTION
Avatar of Scott Fell
Scott Fell
Flag of United States of America image

Link to home
membership
Create an account to see this answer
Signing up is free. No credit card required.
Create Account